Bug 849920 - [Hyper-V] i386 PAE guest could not pass the TSC test in monotonic_time test
[Hyper-V] i386 PAE guest could not pass the TSC test in monotonic_time test
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: jason wang
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 04:42 EDT by Shengnan Wang
Modified: 2013-04-23 11:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-23 11:02:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shengnan Wang 2012-08-21 04:42:24 EDT
RHEL5.9 Hyper-V i386 PAE guest could not pass the monotonic_time test


Description of problem:
The i386PAE Hyper-V guest with hyperv_clocksource as the clocksource didn't pass the monotonic_time test. The TSC test in the monotonic_time test failed. Run the test TSC for 300s, the time interface went backwards by 88150 CPU clock cycles.

# cat /sys/devices/system/clocksource/clocksource0/current_clocksource
hyperv_clocksource 

Test result for: 2.6.18-336.el5PAE 
START   ----    ----    timestamp=1345427596    localtime=Aug 20 09:53:16
        START   monotonic_time.gtod     monotonic_time.gtod     timestamp=1345427596    localtime=Aug 20 09:53:16
                GOOD    monotonic_time.gtod     monotonic_time.gtod     timestamp=1345427900    localtime=Aug 20 09:58:20       completed successfully
        END GOOD        monotonic_time.gtod     monotonic_time.gtod     timestamp=1345427900    localtime=Aug 20 09:58:20
        START   monotonic_time.clock    monotonic_time.clock    timestamp=1345427900    localtime=Aug 20 09:58:20
                GOOD    monotonic_time.clock    monotonic_time.clock    timestamp=1345428205    localtime=Aug 20 10:03:25       completed successfully
        END GOOD        monotonic_time.clock    monotonic_time.clock    timestamp=1345428205    localtime=Aug 20 10:03:25
        START   monotonic_time.tsc      monotonic_time.tsc      timestamp=1345428205    localtime=Aug 20 10:03:25
                FAIL    monotonic_time.tsc      monotonic_time.tsc      timestamp=1345428511    localtime=Aug 20 10:08:31       FAIL: tsc-worst-warp=-88150
        END FAIL        monotonic_time.tsc      monotonic_time.tsc      timestamp=1345428511    localtime=Aug 20 10:08:31
END GOOD        ----    ----    timestamp=1345428511    localtime=Aug 20 10:08:31



Version-Release number of selected component (if applicable):
Host: Windows 2008 R2 Hyper-V (6.1.7600.16385)
Guest: RHEL5.9 guest (2.6.18-336.el5PAE)
Pv drivers: 
# lsmod |grep hv_*
hid_base_hv            68177  1 hid_hyperv
hv_netvsc              25665  0 
hv_utils               12001  0 
hv_storvsc             17601  3 
hv_vmbus               30265  4 hid_hyperv,hv_netvsc,hv_utils,hv_storvsc


Guest cpuflags:
processor	: 2
vendor_id	: GenuineIntel
cpu family	: 6
model		: 26
model name	: Intel(R) Xeon(R) CPU           E5530  @ 2.40GHz
stepping	: 5
cpu MHz		: 2366.078
cache size	: 8192 KB
physical id	: 0
siblings	: 3
core id		: 2
cpu cores	: 3
apicid		: 2
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ss ht syscall nx lm constant_tsc pni ssse3 cx16 sse4_1 sse4_2 popcnt lahf_lm
bogomips	: 13633.84


How reproducible:
100%

Steps to Reproduce:
1. Create the Hyper-V guest.
2. Down load the autotest tools. Use the git repo  KVM team:
        $git clone git://qe-git.englab.nay.redhat.com/s2/autotest
3. Run the monotonic_time in autotest:
    # cd <autotest>/client/tests/monotonic_time/
    # ../../bin/autotest control --verbose
  
Actual results:
At step3, the guest should pass the TSC test without ' END FAIL'.

Expected results:
At step3, the TSC test failed with the error info ' FAIL: tsc-worst-warp=-88150'.

Additional info:
1.Test it on Hyper-V x86_64 guest. The x86_64 Hyper-V guest pass the monotonic_time test.
Comment 3 Ronen Hod 2012-08-23 03:41:00 EDT
Since there was no crash, and we are late in RHEL5.9, postponing to 5.10.
Comment 5 Qin Guan 2013-03-21 02:15:36 EDT
Problem happen on both x86_64 and i386 guests, and only when smp=2.

Append more information here:

1. The status:

	START	monotonic_time.tsc	monotonic_time.tsc	timestamp=1363816279	localtime=Mar 21 05:51:19	
		FAIL	monotonic_time.tsc	monotonic_time.tsc	timestamp=1363816584	localtime=Mar 21 05:56:24	FAIL: tsc-worst-warp=-17344121
	END FAIL	monotonic_time.tsc	monotonic_time.tsc	timestamp=1363816585	localtime=Mar 21 05:56:25	

2. The message of monotonic_time.tsc.DEBUG:

03/21 05:51:22 DEBUG|base_utils:0077| Running 'which gcc'
03/21 05:51:22 DEBUG|base_utils:0114| [stdout] /usr/bin/gcc
03/21 05:51:22 DEBUG|base_utils:0077| Running '/nfs-8-140/work/auto/autotest.s2/autotest/client/tests/monotonic_time/src/time_test --duration 300 tsc'
03/21 05:56:23 INFO |monotonic_:0031| Time test command exit status: 1
03/21 05:56:23 ERROR|      test:0420| Exception escaping from test:
Traceback (most recent call last):
  File "/nfs-8-140/work/auto/autotest.s2/autotest/client/common_lib/test.py", line 417, in _exec
    _call_test_function(self.execute, *p_args, **p_dargs)
  File "/nfs-8-140/work/auto/autotest.s2/autotest/client/common_lib/test.py", line 838, in _call_test_function
    return func(*args, **dargs)
  File "/nfs-8-140/work/auto/autotest.s2/autotest/client/common_lib/test.py", line 290, in execute
    postprocess_profiled_run, args, dargs)
  File "/nfs-8-140/work/auto/autotest.s2/autotest/client/common_lib/test.py", line 210, in _call_run_once
    self.run_once(*args, **dargs)
  File "/nfs-8-140/work/auto/autotest.s2/autotest/client/tests/monotonic_time/monotonic_time.py", line 37, in run_once
    raise error.TestFail(line)
TestFail: FAIL: tsc-worst-warp=-17344121
[root@localhost monotonic_time]#
Comment 6 Ronen Hod 2013-03-28 05:01:12 EDT
KY,

Any plans for RHEL5.10?
Comment 7 Ronen Hod 2013-04-23 11:02:23 EDT
Closing. We decided not to fix it in RHEL5.

Note You need to log in before you can comment on or make changes to this bug.