Bug 849921 - "VIRTWHO_INTERVAL" can't work
"VIRTWHO_INTERVAL" can't work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity high
: beta
: ---
Assigned To: Radek Novacek
Entitlement Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 04:46 EDT by Hui Wang
Modified: 2016-11-30 19:30 EST (History)
8 users (show)

See Also:
Fixed In Version: virt-who-0.7-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:35:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hui Wang 2012-08-21 04:46:10 EDT
Description of problem:
If set the config option "VIRTWHO_INTERVAL=N" in /etc/sysconfig/virt-who, virt-who should be send the current host/guest uuids infos to SAM server. But now it can't work.

Version-Release number of selected component (if applicable):
virt-who-0.7-2.el5
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5
python-rhsm-1.0.5-1.el5
katello-headpin-all-0.2.13-1.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch

How reproducible:
100%

Steps to Reproduce:
1. Config the virt-who config file
   # vi /etc/sysconfig/virt-who
    VIRTWHO_BACKGROUND=1 
    VIRTWHO_DEBUG=1 
    VIRTWHO_INTERVAL=1
2. Register system to SAM
3. Start virt-who service
# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
4.Check the log in /var/log/rhsm/rhsm.log
[root@localhost ~]# tail -f /var/log/rhsm/rhsm.log
....
2013-01-14 00:42:14,321 [DEBUG]  @virt.py:72 - EVENT: Domain testr(1) Started Booted
2013-01-14 00:42:14,322 [DEBUG]  @virt.py:56 - Virtual machine found: testr: 43e5713c-2ce4-47b0-0569-76c9ecbf2b32
2013-01-14 00:42:14,329 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['43e5713c-2ce4-47b0-0569-76c9ecbf2b32']

^^^^^^^^The log does not update if there are no new event. But it is different from the interpretation in the /etc/sysconfig/virt-who file:
# Acquire and send list of virtual guest each N seconds, 0 means default configuration.
#VIRTWHO_INTERVAL=1
  
Actual results:
After setting the "VIRTWHO_INTERVAL=N", it can't be work.

Expected results:
After setting the "VIRTWHO_INTERVAL=N", it should be work.

Additional info:
Comment 1 RHEL Product and Program Management 2012-08-21 04:58:30 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Radek Novacek 2012-08-23 05:42:14 EDT
This bug has been fixed in virt-who-0.7-3.el5.
Comment 5 Hui Wang 2012-08-27 23:21:20 EDT
Verified.

Version: 
virt-who-0.7-4.el5
subscription-manager-firstboot-1.0.13-1.el5
subscription-manager-1.0.13-1.el5
subscription-manager-gui-1.0.13-1.el5
python-rhsm-1.0.5-1.el5
katello-headpin-all-0.2.13-1.el6_2.noarch
candlepin-0.6.5-1.el6_2.noarch

Steps:
1. Config the virt-who config file
   # vi /etc/sysconfig/virt-who
    VIRTWHO_BACKGROUND=1 
    VIRTWHO_DEBUG=1 
    VIRTWHO_INTERVAL=1
2. Register system to SAM
3. Start virt-who service
# service virt-who restart
Stopping virt-who:                                         [  OK  ]
Starting virt-who:                                         [  OK  ]
4.Check the log in /var/log/rhsm/rhsm.log
# tail -f /var/log/rhsm/rhsm.log
    sys.exit(0)
SystemExit: 0
2013-01-20 21:08:53,090 [ERROR]  @virt-who.py:167 - Unable to recover, retry in 1 seconds.
2013-01-20 21:08:56,486 [DEBUG]  @virt-who.py:410 - Starting event loop
2013-01-20 21:08:56,551 [DEBUG]  @virt-who.py:428 - Virt-who is running in libvirt mode
2013-01-20 21:08:56,551 [DEBUG]  @virt-who.py:435 - Starting infinite loop with 1 seconds interval and event handling
2013-01-20 21:08:56,552 [DEBUG]  @virt.py:56 - Virtual machine found: test2: 6b170a2c-5966-63e7-a970-c571bb45ff5a
2013-01-20 21:08:56,552 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['6b170a2c-5966-63e7-a970-c571bb45ff5a']
2013-01-20 21:08:58,255 [DEBUG]  @virt.py:56 - Virtual machine found: test2: 6b170a2c-5966-63e7-a970-c571bb45ff5a
2013-01-20 21:08:58,255 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['6b170a2c-5966-63e7-a970-c571bb45ff5a']
2013-01-20 21:08:59,883 [DEBUG]  @virt.py:56 - Virtual machine found: test2: 6b170a2c-5966-63e7-a970-c571bb45ff5a
2013-01-20 21:08:59,883 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['6b170a2c-5966-63e7-a970-c571bb45ff5a']
2013-01-20 21:09:01,313 [DEBUG]  @virt.py:56 - Virtual machine found: test2: 6b170a2c-5966-63e7-a970-c571bb45ff5a
Comment 7 errata-xmlrpc 2013-01-08 02:35:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0072.html

Note You need to log in before you can comment on or make changes to this bug.