Bug 849923 - Process import in Designer on EAP 6.0: java.io.IOException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
Process import in Designer on EAP 6.0: java.io.IOException: SAX2 driver class...
Status: VERIFIED
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5 (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity medium
: ER2
: BRMS 5.3.1 GA
Assigned To: Tihomir Surdilovic
Marek Baluch
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 05:00 EDT by Jiri Svitak
Modified: 2015-06-01 21:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 02:17:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (7.99 KB, text/plain)
2012-08-21 05:00 EDT, Jiri Svitak
no flags Details
testproc.bpmn2 (4.17 KB, text/plain)
2012-08-21 05:02 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2012-08-21 05:00:48 EDT
Created attachment 605886 [details]
server.log

Process import in Designer (BRMS 5.3.0.GA patch01) deployed on EAP 6.0 has problems that were not found on EAP 5.0.

Steps to reproduce:
1. Deploy BRMS 5.3.0 patch01 on EAP 6.0 using steps described here:
https://docspace.corp.redhat.com/docs/DOC-111367
2. Open jboss-brms
3. Create package com.sample
4. Import an attached BPMN process (has a different package 'test', it's an intent)
5. Try to validate the process definition, you'll see several problems, so
correct package name of the process, generate task forms and generate .png file
6. .png file is generated in the package, but cannot be downloaded, because Firefox opens this new tab 'Problem loading pade' with content:
"File not found
Firefox can't find the file at http://localhost:8080/designer/transformer?uuid=30a0d6dc-4d89-4918-b838-400416b68193&profile=jbpm."
This happens even when you have corrected the package name to com.sample
Process validation says "There are no validation errors".
7. An exception is thrown complaining about missing SAXParser, see attached server.log
Comment 1 Jiri Svitak 2012-08-21 05:02:09 EDT
Created attachment 605888 [details]
testproc.bpmn2
Comment 2 Tihomir Surdilovic 2012-08-26 13:25:01 EDT
Designer has two separate deployables, one for EAP5/AS5 and a separate one for EAP6/AS7. I am not sure which deployable was used during testing. If I could get more info on how to reproduce this it would really help as we havent seen this error in the community yet.
Comment 3 Lukáš Petrovický 2012-08-27 02:27:54 EDT
(In reply to comment #2)
> Designer has two separate deployables, one for EAP5/AS5 and a separate one
> for EAP6/AS7.

In product, it doesn't. We only have one. CCing Ryan as this may be his territory now.
Comment 4 Tihomir Surdilovic 2012-08-28 08:22:27 EDT
I am not getting this with EAP 6.0 and the designer war for AS7. I do get a warning on server startup (before wars get deployed):

08:19:30,099 WARN  [org.jboss.as.ee] (MSC service thread 1-3) JBAS011006: Not installing optional component org.apache.cxf.transport.http.Servlet3ContinuationProvider$Servlet3Continuation due to exception: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011054: Could not find default constructor for class org.apache.cxf.transport.http.Servlet3ContinuationProvider$Servlet3Continuation
	at org.jboss.as.ee.component.ComponentDescription$DefaultComponentConfigurator.configure(ComponentDescription.java:606) [jboss-as-ee-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.ee.component.deployers.EEModuleConfigurationProcessor.deploy(EEModuleConfigurationProcessor.java:83) [jboss-as-ee-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:116)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [classes.jar:1.6.0_33]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [classes.jar:1.6.0_33]
	at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_33]

But don't think it is related to Designer. Designer does not use apache cxf, but afaik Guvnor does so this might be an issue with Guvnor?
Comment 6 Jiri Svitak 2012-09-13 12:28:35 EDT
Reopening the Bugzilla, because BRMS 5.3.1 ER1 build has not solved this problem.
The same exception is thrown on EAP 6.0 with ee6 wars. I have tested the same steps (create a package, import the process definition, generate task forms and create a .png image). I have tried the same steps also on BRMS 5.3.1 ER1 standalone (with EAP 5 and the same version of the Designer - 2.3.1-DEV), but everything worked fine, so the bug is EAP6 specific.

Note:
With ee6 brms wars you don't have to care about configuring persistence that much, only configure datasource for brms in jboss. But still you have to configure netty library, security domain, users and their roles. You can find these details in the doc https://docspace.corp.redhat.com/docs/DOC-111367.

My environment:
EAP 6.0
BRMS 5.3.1 ER1 (Designer 2.3.1-DEV) ee6 deployable wars
Comment 7 Julian Coleman 2012-10-01 12:13:16 EDT
Resolved with revision 11538 of:

  brmso-p/src/main/assembly/jbpm-console-ee6.zip.xml
  brms-p/src/main/patches/processdesigner/patch_designer_conf.xml
  brms-p/pom.xml


Commit message:
  BZ-849923
  Use the designer jboss7 war for the jBPM console EE6 zip and don't exclude
  jar files from it.  Also apply the jbpm.xml patches to the designer EE6 war.
Comment 8 Jiri Svitak 2012-10-04 11:40:14 EDT
Verified in BRMS 5.3.1 ER2.
Comment 9 lcarlon 2012-11-05 20:44:27 EST
Marked as no release note required as EAP6 support is new for BRMS 5.3.1

Note You need to log in before you can comment on or make changes to this bug.