Bug 849947 - didn't see hwtable_regex_match in multipath built-in configuration
didn't see hwtable_regex_match in multipath built-in configuration
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: LVM and device-mapper development team
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 05:59 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:27:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaowei Li 2012-08-21 05:59:54 EDT
Description of problem:
I didn't see the hwtable_regex_match in /usr/share/doc/device-mapper-multipath-0.4.9 and the output of 'multipathd show config'


Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-26.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ben Marzinski 2012-08-22 14:27:48 EDT
That's because the old way caused lots of problems.  Upstream switched entirely to the regex-version, which works much better.  We couldn't switch by default in RHEL6 because it would mess with existing configurations.  But in RHEL7, the straight string matching method has been removed.  Now hwtable entries always are matched by regular expressions.

Note You need to log in before you can comment on or make changes to this bug.