Bug 849985 - perl version/invocation failure during publican run
perl version/invocation failure during publican run
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ImageMagick (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Benjamin Tissoires
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 08:23 EDT by Frank Ch. Eigler
Modified: 2014-02-19 09:04 EST (History)
1 user (show)

See Also:
Fixed In Version: ImageMagick-6.7.8.9-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-19 09:04:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2012-08-21 08:23:43 EDT
During a systemtap documentation build via publican, the following is seen:

touch stamp-mandocs
make[3]: Leaving directory `/builddir/build/BUILD/systemtap-2.0/doc/SystemTap_Tapset_Reference'
Making all in beginners
make[3]: Entering directory `/builddir/build/BUILD/systemtap-2.0/doc/beginners'
publican build --formats=pdf,html --langs=en-US && \
mv build/en-US/pdf/*SystemTap_Beginners_Guide*.pdf SystemTap_Beginners_Guide.pdf
Perl API version v5.14.0 of Image::Magick does not match v5.16.0 at /usr/lib64/perl5/DynaLoader.pm line 213, <DATA> line 1662.
Compilation failed in require at /usr/share/perl5/vendor_perl/Publican/XmlClean.pm line 11, <DATA> line 1662.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Publican/XmlClean.pm line 11, <DATA> line 1662.
Compilation failed in require at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 10, <DATA> line 1662.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Publican/Builder.pm line 10, <DATA> line 1662.
Compilation failed in require at /usr/share/perl5/vendor_perl/Publican/CreateBook.pm line 13, <DATA> line 1662.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/Publican/CreateBook.pm line 13, <DATA> line 1662.
Compilation failed in require at /usr/bin/publican line 17, <DATA> line 1662.
BEGIN failed--compilation aborted at /usr/bin/publican line 17, <DATA> line 1662.
&Image::Magick::constant not defined. The required ImageMagick libraries are not installed or not installed properly.
END failed--call queue aborted at /usr/bin/publican line 17, <DATA> line 1662.
make[3]: *** [SystemTap_Beginners_Guide.pdf] Error 22
Comment 4 Benjamin Tissoires 2014-02-19 09:04:19 EST
The bug was open during early stages of RHEL 7, and we are not able to reproduce it anymore.

Note You need to log in before you can comment on or make changes to this bug.