Bug 850014 - 3.1 [vdsm] [Host Networking] DC/CL 3.0 cannot edit VLAN interface IP after duplicate IP address assignment
3.1 [vdsm] [Host Networking] DC/CL 3.0 cannot edit VLAN interface IP after du...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Igor Lvovsky
Martin Pavlik
network
:
Depends On: 853060
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 09:16 EDT by Martin Pavlik
Modified: 2015-04-06 23:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 03:06:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (6.16 KB, application/x-gzip)
2012-08-21 09:16 EDT, Martin Pavlik
no flags Details
screenshot 1 (249.25 KB, image/png)
2012-08-21 09:22 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-08-21 09:16:23 EDT
Created attachment 605933 [details]
vdsm.log + engine.log

Description of problem:
DC/CL 3.0
It is not possible to assign correct IP address to VLAN interface after duplicate IP assignemet was attempted. See reproduction steps for detailed info.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: '3.1.0-12.el6ev' 

How reproducible:
100%

Steps to Reproduce:
1. Create 2 VLAN networks
2. Assign botn VLANs to one host NIC with Boot Protocol=none
3. Assign first VLAN with static IP (e.g. 10.10.10.10/24)
4. Assign second VLAN with SAME static IP (e.g. 10.10.10.10/24) -> following error will appear: Error while executing action Update Network to Host Interface: Illegal or Incomplete IP Address
5. Click OK
6. Assign second VLAN with DIFFERENT static IP (e.g. 10.10.11.11/24) -> following error will appear: Error while executing action Update Network to Host Interface: Unexpected exception

  
Actual results:
once duplicate IP address is used it is not possible to assign any other IP

Expected results:
after atempt of duplicte IP assignment it should be possible to enter correct IP

Additional info:
MainProcess|Thread-6127::ERROR::2012-08-21 12:45:23,644::supervdsmServer::32::SuperVdsm.ServerCallback::(wrapper) Error in editNetwork
Traceback (most recent call last):
  File "/usr/share/vdsm/supervdsmServer.py", line 30, in wrapper
  File "/usr/share/vdsm/supervdsmServer.py", line 78, in editNetwork
  File "/usr/share/vdsm/configNetwork.py", line 609, in editNetwork
  File "/usr/share/vdsm/configNetwork.py", line 593, in delNetwork
  File "/usr/share/vdsm/configNetwork.py", line 505, in removeLibvirtNetwork
  File "/usr/lib64/python2.6/logging/__init__.py", line 1489, in debug
  File "/usr/lib64/python2.6/logging/__init__.py", line 1044, in debug
TypeError: _log() got an unexpected keyword argument 'exec_info'
Comment 1 Martin Pavlik 2012-08-21 09:19:37 EDT
[root@dell-r210ii-08 ~]# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 6.3 (20120813.0.el6_3)

libvirt-0.9.10-21.el6_3.3.x86_64
qemu-img-rhev-0.12.1.2-2.295.el6.x86_64
vdsm-4.9-113.1.el6.x86_64
Comment 2 Martin Pavlik 2012-08-21 09:22:28 EDT
Created attachment 605935 [details]
screenshot 1
Comment 3 lpeer 2012-08-21 13:07:41 EDT
Assigning duplicate ip should be blocked in the engine, for 3.1 cluster it was fixed in BZ 839199.

Leaving this bug on vdsm to look what went wrong.
Comment 4 Martin Pavlik 2012-08-22 02:11:53 EDT
(In reply to comment #3)
> Assigning duplicate ip should be blocked in the engine, for 3.1 cluster it
> was fixed in BZ 839199.
> 
> Leaving this bug on vdsm to look what went wrong.

Just to make things clear, you cannot assign duplicate IP, engine will prevent this, however after you try to do so, you cannot assign any IP any more, unexpected exception will appear
Comment 5 lpeer 2012-08-22 02:39:30 EDT
> Just to make things clear, you cannot assign duplicate IP, engine will
> prevent this, however after you try to do so, you cannot assign any IP any
> more, unexpected exception will appear

Engine should block this but it looks like it goes all the way to vdsm and blocked in vdsm.
Comment 6 Igor Lvovsky 2012-08-30 03:46:28 EDT
According to comment 1, this is relevant for vdsm-4.9-113.1.el6.x86_64
that is a 3.0.z build

In 3.1 vdsm it's already fixed.

Livnat, do you want to mark it as 3.0 in subject?
Do you want to fix it there?
Comment 7 Igor Lvovsky 2012-08-30 03:57:48 EDT
I just checked it again
and this bug already solved in 3.0.z too

vdsm-4.9-113.3.el6.x86_64

Martin, please recheck it and close.
Comment 8 lpeer 2012-08-30 06:23:21 EDT
(In reply to comment #5)
> > Just to make things clear, you cannot assign duplicate IP, engine will
> > prevent this, however after you try to do so, you cannot assign any IP any
> > more, unexpected exception will appear
> 
> Engine should block this but it looks like it goes all the way to vdsm and
> blocked in vdsm.

Engine already handles this as well.
Martin please see if you can reproduce and close if not.
Comment 9 Martin Pavlik 2012-08-30 08:22:44 EDT
(In reply to comment #8)
> (In reply to comment #5)
> > > Just to make things clear, you cannot assign duplicate IP, engine will
> > > prevent this, however after you try to do so, you cannot assign any IP any
> > > more, unexpected exception will appear
> > 
> > Engine should block this but it looks like it goes all the way to vdsm and
> > blocked in vdsm.
> 
> Engine already handles this as well.
> Martin please see if you can reproduce and close if not.

I tried but I run into #BZ853060 which prevents me from adding static IP to VLAN. Need to get back to this when #BZ853060 is solved.
Comment 10 Igor Lvovsky 2012-09-10 04:37:57 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #5)
> > > > Just to make things clear, you cannot assign duplicate IP, engine will
> > > > prevent this, however after you try to do so, you cannot assign any IP any
> > > > more, unexpected exception will appear
> > > 
> > > Engine should block this but it looks like it goes all the way to vdsm and
> > > blocked in vdsm.
> > 
> > Engine already handles this as well.
> > Martin please see if you can reproduce and close if not.
> 
> I tried but I run into #BZ853060 which prevents me from adding static IP to
> VLAN. Need to get back to this when #BZ853060 is solved.

bug 853060 already solved.
Comment 11 Martin Pavlik 2012-09-19 03:06:12 EDT
verified on SI18 everything works fine

Note You need to log in before you can comment on or make changes to this bug.