This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 850111 - qpid-stat -c mech column data missing
qpid-stat -c mech column data missing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-tools (Show other bugs)
Development
Unspecified Unspecified
high Severity high
: 2.2
: ---
Assigned To: Ted Ross
Leonid Zhaldybin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 09:36 EDT by Frantisek Reznicek
Modified: 2014-11-09 17:38 EST (History)
7 users (show)

See Also:
Fixed In Version: qpid-tools-0.14-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 07:42:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Reznicek 2012-08-21 09:36:14 EDT
Description of problem:

qpid-stat -c shows details about live qpidd connections.

There are mech and auth columns which should help user to gather information whether clients are requesting authentication.

Apparently provided information does not reflect whether authentication is even done.

For instance when broker run in auth=no:

[root@mrg-qe-01 ~]# qpid-stat -c
Connections
  client-addr                          mech        auth         connected
  =======================================================================
  10.3x.33.54:5672-10.3x.26.251:40860  guest@QPID  -2938063773  0s       
  10.3x.33.54:5672-10.3x.26.251:40861  guest@QPID  -2942858705  0s       
  10.3x.33.54:5672-10.3x.26.251:40862  guest@QPID  -2947812637  0s       
  127.0.0.1:5672-127.0.0.1:39512       anonymous   -5096273974  0s       

in auth=yes:
Connections
  client-addr                          mech            auth         connected
  ===========================================================================
  10.3x.33.54:5672-10.3x.26.251:40878  guest@QPID      785161405    0s       
  10.3x.33.54:5672-10.3x.26.251:40879  guest@QPID      780000858    0s       
  127.0.0.1:5672-127.0.0.1:39516       anonymous@QPID  -1594676636  0s       
  10.3x.33.54:5672-10.3x.26.251:40877  guest@QPID      790342704    0s       

So in other words there is no information in the table whether requested mechanism is used or not which is misleading.

qpid-stat -c table should somehow inform the user that mechanism is requested, but finally not used.
There are multiple ways how to do that:
- adding column for negotiated authentication method
or
- closing mech value in brackets when it is not used (guest@QPID)


Version-Release number of selected component (if applicable):
python-qpid-0.14-11.el5.noarch
python-qpid-qmf-0.14-14.el5.i386
qpid-cpp-client-0.14-21.el5.i386
qpid-cpp-client-devel-0.14-21.el5.i386
qpid-cpp-client-devel-docs-0.14-21.el5.i386
qpid-cpp-client-rdma-0.14-21.el5.i386
qpid-cpp-client-ssl-0.14-21.el5.i386
qpid-cpp-mrg-debuginfo-0.14-21.el5.i386
qpid-cpp-server-0.14-21.el5.i386
qpid-cpp-server-cluster-0.14-21.el5.i386
qpid-cpp-server-devel-0.14-21.el5.i386
qpid-cpp-server-rdma-0.14-21.el5.i386
qpid-cpp-server-ssl-0.14-21.el5.i386
qpid-cpp-server-store-0.14-21.el5.i386
qpid-cpp-server-xml-0.14-21.el5.i386
qpid-java-client-0.18-1.el5.noarch
qpid-java-common-0.18-1.el5.noarch
qpid-java-example-0.18-1.el5.noarch
qpid-jca-0.18-1.el5.noarch
qpid-jca-xarecovery-0.18-1.el5.noarch
qpid-jca-zip-0.18-1.el5.noarch
qpid-qmf-0.14-14.el5.i386
qpid-qmf-debuginfo-0.14-14.el5.i386
qpid-qmf-devel-0.14-14.el5.i386
qpid-tests-0.14-1.el5.noarch
qpid-tools-0.14-5.el5.noarch
rh-qpid-cpp-tests-0.14-21.el5.i386
ruby-qpid-qmf-0.14-14.el5.i386


How reproducible:
100%

Steps to Reproduce:
1. qpidd in auth=no and then auth=yes
2a. qpid-perftest -b <host> -s --user guest --password guest --mechanism PLAIN
2b. qpid-perftest -b <host> -s --user guest --password guest --mechanism ANONYMOUS
3. qpid-stat -c
  
Actual results:
It is not clear whether information from mech column refers to requested or established authentication mode.

Expected results:
It should be clear what mech column represents and user should get information whether listed authentication mode is used.

Additional info:
Comment 9 Leonid Zhaldybin 2012-08-30 04:22:11 EDT
The problem is still present in the latest build:

[root@lzhaldyb-rhel63x ~]# qpid-stat -c
Connections
  client-addr             cproc          cpid  auth            connected  idle  msgIn  msgOut
  =============================================================================================
  [::1]:5672-[::1]:45278  qpid-perftest  5083  user@QPID       5s         0s      17    448k
  [::1]:5672-[::1]:45279  qpid-perftest  5083  user@QPID       5s         0s      28     13
  [::1]:5672-[::1]:45280  qpid-stat      5087  anonymous@QPID  1s         0s     247    316
  [::1]:5672-[::1]:45275  sesame         1487  anonymous@QPID  9s         0s      35     23
  [::1]:5672-[::1]:45277  qpid-perftest  5083  user@QPID       5s         0s     486k    17

As this qpid-stat output shows, the "mech" column is not shown at all now. I'm returning this back to assigned.

-> ASSIGNED
Comment 11 Leonid Zhaldybin 2012-08-30 04:34:19 EDT
I forgot to add the package version used for testing, sorry:

qpid-tools-0.14-6.el5
qpid-tools-0.14-6.el6_3.noarch

Note You need to log in before you can comment on or make changes to this bug.