Bug 85030 - Don't allow usernames <=2 characters.
Don't allow usernames <=2 characters.
Status: CLOSED WONTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Orazi
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-24 18:29 EST by Chris Kloiber
Modified: 2008-02-13 15:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 15:11:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2003-02-24 18:29:40 EST
rhn_register as shipped in Advanced Server 2.1 seems to have a username length
lower limit of 3 characters, but the RHN website (and probably www.redhat.com as
well) allow usernames with fewer characters. This results in a user who has
entitlements for Advanced Server but can't create system profiles. 

Attempts to use activation keys to work around the problem using rhnreg_ks also
fail with the error:

"too many servers registered using this registration token"

Even though the key was created with no usage limit, and no systems are
currently registered.
Comment 1 Chip Turner 2003-03-03 11:48:59 EST
The RHN website will not let you create users with usernames of fewer than 5
characters.  Where are you seeing this?  are you sure you didn't create the
account on www?  please retry creating an account with fewer characters on
rhn.redhat.com.
Comment 2 Chris Kloiber 2003-03-03 14:17:57 EST
Perhaps the current website code does not allow the creation of usernames of
less than 5 characters. How does it (and rhn_register) handle *existing* short
usernames? That could mean this bug should get reassigned to either the backend
of RHN or to the rhn_register client. The user who had this problem has the
username of 'p2'. You can log into RHN with that account, but you cannot
register a system to that account however.
Comment 3 Bill C. Riemers 2008-02-13 15:11:10 EST
Since nobody has reported this type of problem since 2003, and none of the new
accounts created since have been less than 5 characters, I am closing this bug
as WONTFIX.  If someone does have an existing username with less than 5
characters, we should probably migrate them to a new username.

Note You need to log in before you can comment on or make changes to this bug.