Bug 850447 - Missing module Module org.jboss.logging.jul-to-slf4j-stub:main
Missing module Module org.jboss.logging.jul-to-slf4j-stub:main
Status: CLOSED NOTABUG
Product: JBoss Data Grid 6
Classification: JBoss
Component: Server (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 11:26 EDT by Rafael Benevides
Modified: 2012-08-22 05:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.4 Build Filter: null Build Name: Build Date: 14-06-2012 11:05:28
Last Closed: 2012-08-22 05:52:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Benevides 2012-08-21 11:26:40 EDT
Description of problem: When you deploy the application in library mode on Datagrid Server it stops the deployment with the following stack:

Caused by: org.jboss.modules.ModuleNotFoundException: Module org.jboss.logging.jul-to-slf4j-stub:main is not found in local module loader @56406199 (roots: /java/tools/jboss-datagrid-server-6.0.0.GA/modules)
	at org.jboss.modules.LocalModuleLoader.findModule(LocalModuleLoader.java:126)
	at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:275)
	at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:222)
	at org.jboss.modules.LocalModuleLoader.preloadModule(LocalModuleLoader.java:94)
	at org.jboss.modules.Module.addPaths(Module.java:851)
	at org.jboss.modules.Module.link(Module.java:1206)
	at org.jboss.modules.Module.relinkIfNecessary(Module.java:1235)
	at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:208)
	at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	... 5 more

This module should be implicit as described at https://docs.jboss.org/author/display/AS7/Developer+Guide#DeveloperGuide-Whicharetheimplicitmoduledependencies%3F

Anyway EAP 6.0.0 comes with this module


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tristan Tarrant 2012-08-22 05:52:20 EDT
Applications cannot be deployed to JBoss Data Grid: it is only a server for remote caches.
Library mode applications have to be deployed to EAP.

Note You need to log in before you can comment on or make changes to this bug.