Bug 850474 - RFE add support to keep a claim alive for DAG Submissions.
RFE add support to keep a claim alive for DAG Submissions.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
All Linux
medium Severity high
: ---
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
: FutureFeature, TestOnly
Depends On:
Blocks: 845292
  Show dependency treegraph
 
Reported: 2012-08-21 11:59 EDT by Timothy St. Clair
Modified: 2016-05-26 15:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: condor-7.8.2-0.3
Doc Type: Rebase: Enhancements Only
Doc Text:
Important: if this rebase also contains *bug fixes* (or contains only bug fixes), select the correct option from the Doc Type drop-down list. Rebase package(s) to version: condor-7.8 series Highlights and notable enhancements: When submitting DAGMan jobs users can now supply a +KeepClaimIdle parameter which allows a claim to stay active during the interim period where condor_dagman is submitting new jobs. This enables higher throughput in cases where claims are relinquished prior to new jobs being submitted.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 15:13:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Condor 2094 None None None 2012-08-21 11:59:05 EDT

  None (edit)
Description Timothy St. Clair 2012-08-21 11:59:05 EDT
A common use case which affects utilization is the case where the claim divy'd out to a DAG job was relinquished because DAGman had not submitted a new job in time for the it to be reused by the autocluster.  

This ticket is to capture the addition of 

  +KeepClaimIdle parameter 

which keeps the claim alive long enough so that it can be reused by a DAG
Comment 4 Anne-Louise Tangring 2016-05-26 15:13:01 EDT
MRG-G is in maintenance only and only customer escalations will be addressed from this point forward. This issue can be re-opened if a customer escalation associated with this issue occurs.

Note You need to log in before you can comment on or make changes to this bug.