This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 850499 - CLI option required to dump event history
CLI option required to dump event history
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Raghavendra Bhat
SATHEESARAN
: FutureFeature
Depends On: 846192
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 12:48 EDT by Vidya Sakar
Modified: 2013-09-23 18:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 846192
Environment:
Last Closed: 2013-09-23 18:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-21 12:48:16 EDT
+++ This bug was initially created as a clone of Bug #846192 +++

Command line option is required to dump the event history.
Comment 2 Raghavendra Bhat 2012-10-09 02:09:40 EDT
gluster volume statedump <volname> history will dump the event history to the statedump file. As of now patches have been submitted to integrate event-history with fuse and trace xlators.
Comment 3 SATHEESARAN 2013-01-09 08:30:56 EST
Bug verification blocked by 888238.
so glusterd fails, when trying to issue the command - " gluster volume statedump <vol-name>".

Unable to check the working of command - "gluster volume statedump <vol-name> history.

Also fixed in version should be - glusterfs 3.4.0-qa6 and not glusterfs 3.4.0-qa5

Under all this conditions moving this bug to ASSIGNED state
Comment 4 Raghavendra Bhat 2013-01-11 05:26:36 EST
(In reply to comment #3)
> Bug verification blocked by 888238.
> so glusterd fails, when trying to issue the command - " gluster volume
> statedump <vol-name>".
> Glusterd fails means is it crashing or the cli command failing? In either case can you attach the logs?

> Unable to check the working of command - "gluster volume statedump
> <vol-name> history.
> 
> Also fixed in version should be - glusterfs 3.4.0-qa6 and not glusterfs
> 3.4.0-qa5
> 
> Under all this conditions moving this bug to ASSIGNED state
Comment 5 Amar Tumballi 2013-01-21 01:44:35 EST
bug 888238 is fixed in qa6 (and now the build is available) so moving the bug again to ON_QA state
Comment 7 SATHEESARAN 2013-07-01 05:54:09 EDT
Tested with glusterfs-3.4.0.11rhs-1 and it works well. Moving it to VERIFIED state
Comment 8 Scott Haines 2013-09-23 18:29:54 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.