Bug 85052 - Word selection crosses new line boundarys
Word selection crosses new line boundarys
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-24 23:15 EST by Emmanuel Galanos
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 20:50:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Galanos 2003-02-24 23:15:00 EST
Description of problem:
In gnome-terminal word selection (double click)
crosses new lines and go up a line.

Version-Release number of selected component (if applicable):
Using beta 5, with vte upgraded to msw's vte-0.10.20-1.i386.rpm
release.

How reproducible:
100 %

Steps to Reproduce:
1. Open up gnome-terminal at standard 80 columns.
2. Run perl -e 'print "AAA  ", "B" x 75, "\n", "CCC\n"'
3. Double click on CCC.
    
Actual results:
Line above gets highlighted.

Expected results:
Only CCC should get highlighted like in Xterm and every other terminal
program since the dawn of humankind.
Comment 1 Ray Strode [halfline] 2004-11-04 20:50:48 EST
This seems fixed now.  If you are still encounter issues with recent
versions of vte please feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.