Bug 850523 - java-1.7.0-openjdk doesn't provide java, jdk, or jre
java-1.7.0-openjdk doesn't provide java, jdk, or jre
Status: CLOSED DUPLICATE of bug 849458
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.7.0-openjdk (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Deepak Bhole
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-21 14:21 EDT by Matthaus Owens
Modified: 2012-08-21 14:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 14:25:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthaus Owens 2012-08-21 14:21:26 EDT
Description of problem:
The newly released openjdk-1.7 provides java7, jdk7, and jre7, but not jdk, java or jre, which makes using it as a packaging dependency challenging.

Version-Release number of selected component (if applicable):
openjdk-1.7 1.7.0.5-2.2.1

How reproducible:
Build or find a package that depends on java >= 1.6.0. Install openjdk-1.7, try to install package that depends on java >= 1.6.0. It will fail.


Steps to Reproduce:
1. Build  or find a package that depends on java >= 1.6.0.
2. Install openjdk-1.7 
3. Try to install package that depends on java >= 1.6.0
  
Actual results:
Package installation fails due to dependency failure, no package provides java >= 1.6.0

Expected results:
Package installation succeeds because openjdk-1.7 is >= 1.6.0.


Additional info:
Comment 2 Deepak Bhole 2012-08-21 14:25:19 EDT
This is a dupe of 849458, closing as such. The provision was intentional for 6.3 and dev can fix it for 6.4 once the acks are there.

*** This bug has been marked as a duplicate of bug 849458 ***

Note You need to log in before you can comment on or make changes to this bug.