This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 850540 - RFE add support for periodic_hold_reason,  periodic_hold_subcode, on_exit_hold_reason, and on_exit_hold_subcode
RFE add support for periodic_hold_reason,  periodic_hold_subcode, on_exit_hol...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
All Linux
low Severity medium
: 3.0
: ---
Assigned To: Timothy St. Clair
Martin Kudlej
: FutureFeature, TestOnly
Depends On:
Blocks: 845292
  Show dependency treegraph
 
Reported: 2012-08-21 15:25 EDT by Timothy St. Clair
Modified: 2013-07-26 04:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: condor-7.8.2-0.2
Doc Type: Rebase: Enhancements Only
Doc Text:
Important: if this rebase also contains *bug fixes* (or contains only bug fixes), select the correct option from the Doc Type drop-down list. Rebase package(s) to version: condor-7.8 series Highlights and notable enhancements: Added the following attributes to a submit description file periodic_hold_reason, periodic_hold_subcode, on_exit_hold_reason, and on_exit_hold_subcode. Permit the job to set a hold reason string and subcode number. Similarly, the system job policy can specify the reason and subcode using SYSTEM_PERIODIC_HOLD_REASON and SYSTEM_PERIODIC_HOLD_SUBCODE . In addition, the condor_hold command now accepts a -subcode option, which is used to set the job attribute HoldReasonSubCode.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 04:05:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Condor 2185 None None None 2012-08-21 15:25:04 EDT

  None (edit)
Description Timothy St. Clair 2012-08-21 15:25:04 EDT
Add the following attributes to a submit description file periodic_hold_reason,  periodic_hold_subcode, on_exit_hold_reason, and on_exit_hold_subcode.  Permit the job to set a hold reason string and subcode number.  Similarly, the system job policy can specify the reason and subcode  using SYSTEM_PERIODIC_HOLD_REASON and SYSTEM_PERIODIC_HOLD_SUBCODE . In  addition, the condor_hold command now accepts a -subcode option, which  is used to set the job attribute HoldReasonSubCode.
Comment 2 Martin Kudlej 2013-07-25 04:51:18 EDT
Tested on RHEL 6.4/5.9 x i386/x86_64 with condor-7.8.8-0.4.3 and it works. -->VERIFIED

Note You need to log in before you can comment on or make changes to this bug.