This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 850582 - RFE allow macros in dagman log files to assist templating
RFE allow macros in dagman log files to assist templating
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
All Linux
medium Severity medium
: ---
: ---
Assigned To: grid-maint-list
MRG Quality Engineering
: FutureFeature
Depends On:
Blocks: 877227
  Show dependency treegraph
 
Reported: 2012-08-21 17:23 EDT by Timothy St. Clair
Modified: 2016-05-26 15:12 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Enhancements Only
Doc Text:
Important: if this rebase also contains *bug fixes* (or contains only bug fixes), select the correct option from the Doc Type drop-down list. Rebase package(s) to version: condor-7.8 series Highlights and notable enhancements: Allows macros in dagman log files to assist templating.
Story Points: ---
Clone Of:
: 877227 (view as bug list)
Environment:
Last Closed: 2016-05-26 15:12:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Condor 2428 None None None 2012-08-21 17:23:20 EDT

  None (edit)
Description Timothy St. Clair 2012-08-21 17:23:20 EDT
Mentioned on condor-users:

Universe   = standard
requirements = (Arch == "X86_64")&&  (OpSys == "LINUX")
Executable = /path/to/binary
transfer_executable = TRUE
should_transfer_files = IF_NEEDED
when_to_transfer_output = ON_EXIT
Arguments  = $(param)
Output     = $(id).stdout
Error      = $(id).stderr
Log        = $(id).condor_log
Queue
NODE_STATUS_FILE dag_status
JOBSTATE_LOG     dag_log
JOB   RT000-rt0.01 itersave.condor_job
VARS  RT000-rt0.01 param="000 GT"
VARS  RT000-rt0.01 id="RT000-rt0.01"
RETRY RT000-rt0.01 3
JOB   RT001-rt0.01 itersave.condor_job
VARS  RT001-rt0.01 param="001 GT"
VARS  RT001-rt0.01 id="RT001-rt0.01"
RETRY RT001-rt0.01 3
(and more)

MultiLogFiles: macros ('$(...') not allowed in log file name
($(id).condor_log) in DAG node submit files
DAGMan strictly protects against possibly changing UserLog files because of the presence of macros. This covers $(Cluster) and $(Process). However, it also covers against VARS ID=ABC, as in this example, a macro that is not variable and instead allows for template submit files.

Proposal is to more narrowly disallow macros (nix Process/Cluster/anything-that-evals-at-submit-time-with-Process-or-Cluster-or-Time-etc) or give users who know what they are doing an escape hatch, a way to say "yes, i'm using macros properly, trust me"
Comment 8 Anne-Louise Tangring 2016-05-26 15:12:34 EDT
MRG-G is in maintenance only and only customer escalations will be addressed from this point forward. This issue can be re-opened if a customer escalation associated with this issue occurs.

Note You need to log in before you can comment on or make changes to this bug.