Bug 850702 - Case Runs per Test Case are not displayed
Case Runs per Test Case are not displayed
Status: CLOSED NOTABUG
Product: TCMS
Classification: Other
Component: Web UI (Show other bugs)
3.8.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Zheng Liu
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 03:41 EDT by Patrik Kis
Modified: 2016-06-23 00:18 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 21:37:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of TCMS (135.39 KB, image/png)
2012-08-22 03:41 EDT, Patrik Kis
no flags Details

  None (edit)
Description Patrik Kis 2012-08-22 03:41:19 EDT
Created attachment 606154 [details]
screenshot of TCMS

Description of problem:
When in a test case the [Case Runs] tab is selected (e.g. in https://tcms.engineering.redhat.com/case/141803/#case_run) it shows the runs collapsed under various test plans but the separated runs are not displayed and expansion does not work.
When click on test plan, the content is not expanded, but the display is redirected to test plan itself.

Version-Release number of selected component (if applicable):
Nitrate 3.8.0

How reproducible:


Steps to Reproduce:
1. Find a test plan which has several runs
2. Choose a test case from that test plans
3. Select the [Case Runs] tab in test plan
4. Try to see the test runs result for that test case
  
Actual results:
Only the test plans are showed from which the test runs were created

Expected results:
Display the test run results for the particular test case

Additional info:
Comment 1 yawei Li 2012-08-22 05:46:40 EDT
The triangle in the front of the plan name can un-collasped the plan. But clicking plan name, it will be redirect to the plan page.

Would you please have a try?
Comment 2 Patrik Kis 2012-08-22 06:37:16 EDT
(In reply to comment #1)
> The triangle in the front of the plan name can un-collasped the plan. But
> clicking plan name, it will be redirect to the plan page.
> 
> Would you please have a try?

I tried, indeed, but it does nothing. Does it work for you? Is it a problem on my side?
Comment 3 Xiangyang Chu 2012-08-23 01:07:40 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > The triangle in the front of the plan name can un-collasped the plan. But
> > clicking plan name, it will be redirect to the plan page.
> > 
> > Would you please have a try?
> 
> I tried, indeed, but it does nothing. Does it work for you? Is it a problem
> on my side?

It works for me on Firefox 14.0.1.
What browser are you using?
Comment 4 Patrik Kis 2012-08-23 02:36:21 EDT
Oops, it works for me too now. I really have no idea what happened, maybe restarted the browser in the meantime, really don't know.
Sorry for bothering; the bug can be closed of course.

Thanks for prompt answer, anyway.

BTW, my browser is Firefox 10.0.5.
Comment 5 Zheng Liu 2012-08-23 21:37:19 EDT
(In reply to comment #4)
> Oops, it works for me too now. I really have no idea what happened, maybe
> restarted the browser in the meantime, really don't know.
> Sorry for bothering; the bug can be closed of course.
> 
> Thanks for prompt answer, anyway.
> 
> BTW, my browser is Firefox 10.0.5.

Thanks for your information. It's possible that JS scripts have not been loaded somehow at first. 
Anyway, it's working now.So close this bug. Please reopen it if happens again.

Note You need to log in before you can comment on or make changes to this bug.