Bug 850716 - Build CapeDwarf in jenkins always fails for missing POM file on website.
Build CapeDwarf in jenkins always fails for missing POM file on website.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Matej Lazar
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 04:28 EDT by Yujie Zhang
Modified: 2015-05-14 22:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:28:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-08-22 04:28:12 EDT
Description of problem:

I created a CapeDwarf application and enabled jenkins for it, when I build it in jenkins, it failed for missing POM file. Then I git clone the app to my local machine, it did miss pom.xml file. This issue does not exist when I created application using quickstart.

Version-Release number of selected component (if applicable):
fork_ami_capedwarf-quickstart-template_36

How reproducible:always


Steps to Reproduce:
1.Go to openshift website and created CapeDwarf application
2.Enable the jenkins for the application
3.Build the application in jenkins
  
Actual results:

It failed for missing POM file.The result is as following:

[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.615s
[INFO] Finished at: Wed Aug 22 03:02:30 EDT 2012
[INFO] Final Memory: 5M/55M
[INFO] ------------------------------------------------------------------------
[WARNING] The requested profile "openshift" could not be activated because it does not exist.
[ERROR] The goal you specified requires a project to execute but there is no POM in this directory (/var/lib/stickshift/e5903342d00e4b608a0037ed866c8a22/jbossas-7/ci/jenkins/workspace/cape222-build). Please verify you invoked Maven from the correct directory. -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MissingProjectException

Build step 'Execute shell' marked build as failure
Archiving artifacts

Finished: FAILURE


Expected results:

Build CapeDwarf in jenkins should be successful.

Additional info:
Comment 1 Yujie Zhang 2012-08-22 05:12:56 EDT
This issue only exist when I use the template on website, but do not exist when I use the quickstart on https://github.com/capedwarf/capedwarf-openshift.
Comment 2 Dan Mace 2012-08-22 10:20:20 EDT
Recategorizing as a Quick Starts bug, as this isn't an issue with the cartridges.
Comment 3 Matej Lazar 2012-08-24 10:53:42 EDT
Changes made only in capedwarf git repo, fork ami did not change.

fork_ami_capedwarf-quickstart-template_36
Comment 4 Yujie Zhang 2012-08-26 23:33:51 EDT
(In reply to comment #3)
Tested this issue on fork_ami_capedwarf-quickstart-template_36, build in jenkins can be successful, so verify this bug.

Note You need to log in before you can comment on or make changes to this bug.