Bug 850728 - Got error sometimes when user register in the Spring Framework app site.
Got error sometimes when user register in the Spring Framework app site.
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 05:03 EDT by Mengjiao Gao
Modified: 2015-05-14 22:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 15:15:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error page when register. (401.84 KB, image/png)
2012-08-22 05:03 EDT, Mengjiao Gao
no flags Details
The app site of JBosseap6 application. (189.54 KB, image/png)
2012-08-23 03:50 EDT, Mengjiao Gao
no flags Details
the jboss server.log when register error. (36.53 KB, text/x-log)
2012-08-23 03:50 EDT, Mengjiao Gao
no flags Details
The git folder cloned of the springInOpenshift application. (212.06 KB, application/x-gzip)
2012-08-26 23:33 EDT, Mengjiao Gao
no flags Details

  None (edit)
Description Mengjiao Gao 2012-08-22 05:03:55 EDT
Created attachment 606179 [details]
Error page when register.

Description of problem:
After I created a Spring Framework on jbosseap application successfully. I open the app url in the brower and tried to register in the app site. Then I got the error page as the attachment shown sometimes .

Version-Release number of selected component (if applicable):
INT

How reproducible:
Random,(50%)

Steps to Reproduce:
1.Created a Spring Framework application.
2.Go to the app site
3.Enter valid name, email and phone number, then click "register".
  
Actual results:
Got error page as attachment show sometimes.

Expected results:
User should register successful without error.

Additional info:
Comment 1 Bill DeCoste 2012-08-22 10:18:49 EDT
Does this happen on local EAP6? Please attach the JBoss server.log
Comment 2 Mengjiao Gao 2012-08-23 03:44:15 EDT
(In reply to comment #1)
> Does this happen on local EAP6? Please attach the JBoss server.log

Do you means that if this issue exists on the Jbosseap6 application? Since the app site of jbosseap6 is just a page like attachment #2 [details] shown, it have no register function in this page.

I have put the Jboss server.log as attachment #3 [details].
Comment 3 Mengjiao Gao 2012-08-23 03:50:06 EDT
Created attachment 606467 [details]
The app site of JBosseap6 application.
Comment 4 Mengjiao Gao 2012-08-23 03:50:57 EDT
Created attachment 606468 [details]
the jboss server.log when register error.
Comment 5 Bill DeCoste 2012-08-23 16:31:34 EDT
Logs are showing Hibernate unique constraint violations. Could you attach the application so I can test?

Also, could you test the application on local (i.e. non-OpenShift) EAP. I suspect this is an issue with the application that's no specific to OpenShift.
Comment 6 Mengjiao Gao 2012-08-26 23:33:08 EDT
Created attachment 607099 [details]
The git folder cloned of  the springInOpenshift application.
Comment 7 Mengjiao Gao 2012-08-26 23:36:38 EDT
(In reply to comment #5)
> Logs are showing Hibernate unique constraint violations. Could you attach
> the application so I can test?
> 
> Also, could you test the application on local (i.e. non-OpenShift) EAP. I
> suspect this is an issue with the application that's no specific to
> OpenShift.

I have tried to create a spring MVC in my local jboss Developer Studio , and countered the same issue.So it may be an issue not specific to openshift.

I have reproduce this issue on production, with user:"mgao+1@redhat.com", passwd:"redhat". I have created a Spring MVC application with the account. The app url is "http://springinopenshift-mgao.rhcloud.com/". I have attached the git folder of the application. You can test via the given url.
Comment 8 Bill DeCoste 2012-08-27 11:14:45 EDT
Is the source for the application available on github? If so, I'll take a look. Sounds like a bug in the app.
Comment 9 Mengjiao Gao 2012-08-27 22:41:39 EDT
(In reply to comment #8)
> Is the source for the application available on github? If so, I'll take a
> look. Sounds like a bug in the app.

I have attached the source folder of my Spring application in comment #6. You can download that to look.

Note You need to log in before you can comment on or make changes to this bug.