Bug 850797 - File calc64.h not found in kernel-devel package.
File calc64.h not found in kernel-devel package.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 08:46 EDT by Miguel Perez Colino
Modified: 2014-09-29 11:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:19:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miguel Perez Colino 2012-08-22 08:46:57 EDT
Description of problem:
File calc64.h not found in kernel-devel package in RHEL 5.8, but was available in RHEL 5.7. 
* RHEL 5.8 package version: kernel-devel-2.6.18-308.8.2.el5
* RHEL 5.7 package version: kernel-devel-2.6.18-274.el5

Version-Release number of selected component (if applicable):


How reproducible:
When building foreign kernel modules, in this case "deadman" module for serviceguard, compilation fails because file calc64.h is not found. 
[serviceguard-A.11.18.01-0.rhel5]

Steps to Reproduce:
1. Get a module source that depends on calc64.h
2. Try to build it.
  
Actual results:
Module does not build.

Expected results:
Module gets built.

Additional info:
* Changing linux/calc64.h for asm/div64.h in source code enables the build.
* ServiceGuard installs correctly in RHEL 5.7 but not in 5.8 due to this issue. This can become a problem for an important customer that we have.
Comment 1 RHEL Product and Program Management 2014-03-07 08:45:32 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:19:49 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.