Bug 850839 - unit for new device size defaults to bytes if not specified
unit for new device size defaults to bytes if not specified
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 10:07 EDT by Mukundan Ragavan
Modified: 2012-11-26 11:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-26 11:30:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attachment showing size of partition entered (112.29 KB, image/png)
2012-08-22 10:47 EDT, Mukundan Ragavan
no flags Details
attachment showing the size of the partition created. (92.42 KB, image/png)
2012-08-22 10:48 EDT, Mukundan Ragavan
no flags Details

  None (edit)
Description Mukundan Ragavan 2012-08-22 10:07:20 EDT
Description of problem:

In the custom partition screen of anaconda, regardless of the size of the partition entered, the installer creates only a 500 MB partition.


Version-Release number of selected component (if applicable):

Fedora 18 - Rawhide anaconda 18.6


How reproducible:

Always

Steps to Reproduce:
1. Select review partition option (not in verbatim form the screen)
2. Choose any partition size and mount point (Say, 4000 MB - see screenshot)
  
Actual results:

A partition is created with size 500 MB instead of the specified size.

Expected results:

Partition with the specified size should be created.

Additional info:

This was attempted on a Virual machine. I was able to complete the installation without problems with automatic partitioning.

Anaconda's automatic partitioning creates partitions of different sizes without problems.

In my search (advanced search in bugzilla & google), I could find any bug report on the same problem. Apologies if this has already been reported.

I can provide any other relevant information if needed.
Comment 1 David Lehman 2012-08-22 10:45:35 EDT
(In reply to comment #0)
> Description of problem:
> 
> In the custom partition screen of anaconda, regardless of the size of the
> partition entered, the installer creates only a 500 MB partition.

Exactly what are you entering in the size entry field?

> Steps to Reproduce:
> 1. Select review partition option (not in verbatim form the screen)
> 2. Choose any partition size and mount point (Say, 4000 MB - see screenshot)

Where is the screenshot?
Comment 2 Mukundan Ragavan 2012-08-22 10:47:50 EDT
Created attachment 606298 [details]
Attachment showing size of partition entered
Comment 3 Mukundan Ragavan 2012-08-22 10:48:25 EDT
Created attachment 606299 [details]
attachment showing the size of the partition created.
Comment 4 Mukundan Ragavan 2012-08-22 10:49:21 EDT
Hi David, Apologize for not attaching the screenshot earlier. As shown in the screenshot, I entered '4000' in the size entry field.
Comment 5 David Lehman 2012-08-22 11:21:49 EDT
If you hold the mouse pointer over the size entry field you should see some text describing how to specify the size. You can now specify sizes in a more flexible format, eg: "25GB", "1024 mb", &c. You have uncovered a bug, however -- if no unit is given, we are defaulting to bytes where we should probably be defaulting to megabytes. The fact that you end up with a size of 500MB in this case is due to some additional logic that I am fixing as well, triggered by a user specifying a very small size (4000 bytes in your case).

Both the default unit and the handling of small sizes will be fixed shortly, but in the meantime you can avoid all this mess by specifying your preferred units.
Comment 6 Mukundan Ragavan 2012-08-22 13:55:36 EDT
Thanks for the input David. Much appreciated.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Mukundan Ragavan 2012-09-13 09:45:25 EDT
I believe this bug has been resolved. As of alpha-RC2 and alpha-RC3, the value defaults to megabytes as it should!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Steve Tyler 2012-11-23 15:24:50 EST
See also:
Bug 868629 - Custom storage "device capacity" usability

Note You need to log in before you can comment on or make changes to this bug.