Bug 850851 - [abrt] wicd-gtk-1.7.2.1-1.fc17: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.KeyError: Traceback (most recent call last):
[abrt] wicd-gtk-1.7.2.1-1.fc17: connection.py:630:call_blocking:DBusException...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wicd (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:d30c17dd8982f11d7cffadec3ac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 10:28 EDT by Jake Jackson
Modified: 2012-10-23 13:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 13:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jake Jackson 2012-08-22 10:28:53 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -O /usr/share/wicd/gtk/wicd-client.py --tray
executable:     /usr/share/wicd/gtk/wicd-client.py
kernel:         3.5.2-1.fc17.x86_64
time:           Wed 22 Aug 2012 06:28:16 PM CEST
uid:            1000

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.KeyError: Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 702, in _message_cb
:    retval = candidate_method(self, *args, **keywords)
:  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1296, in SaveWirelessNetworkProperty
:    config.set(cur_network["bssid"], option, str(cur_network[option]))
:KeyError: dbus.String(u'never', variant_level=1)
:
:
:Traceback (most recent call last):
:  File "/usr/share/wicd/gtk/netentry.py", line 953, in update_neverconnect
:    wireless.SaveWirelessNetworkProperty(self.networkID, "never")
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Python.KeyError: Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 702, in _message_cb
:    retval = candidate_method(self, *args, **keywords)
:  File "/usr/share/wicd/daemon/wicd-daemon.py", line 1296, in SaveWirelessNetworkProperty
:    config.set(cur_network["bssid"], option, str(cur_network[option]))
:KeyError: dbus.String(u'never', variant_level=1)
:
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SystemBus (system) at 0x29becb0>
:args: (0, 'never')
:utf8_strings: False
:bus_name: dbus.UTF8String(':1.3')
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/org/wicd/daemon/wireless'
:timeout: -1.0
:signature: u'vv'
:dbus_interface: 'org.wicd.daemon.wireless'
:message: <dbus.lowlevel.MethodCallMessage object at 0x26f1af8>
:method: 'SaveWirelessNetworkProperty'

smolt_data:
:
:
:General
:=================================
:UUID: 8a3b2b28-f904-48c7-81ba-51d133446006
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4810.92
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
:CPU Stepping: 11
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 4
:CPU Speed: 2394
:System Memory: 7986
:System Swap: 8190
:Vendor: System manufacturer
:System: P5K3 Deluxe System Version
:Form factor: Desktop
:Kernel: 3.5.2-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10688:4163:33429) pci, None, HOST/PCI, 82G33/G31/P35/P31 Express DRAM Controller
:(32902:10689:4163:33429) pci, pcieport, PCI/PCI, 82G33/G31/P35/P31 Express PCI Express Root Port
:(32902:10544:4163:33399) pci, None, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10274:4163:33399) pci, ahci, RAID, 82801 SATA RAID Controller
:(32902:10518:4163:33399) pci, lpc_ich, PCI/ISA, 82801IR (ICH9R) LPC Interface Controller
:(4523:17252:4163:33272) pci, sky2, ETHERNET, 88E8056 PCI-E Gigabit Ethernet Controller
:(32902:10549:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:9294:4163:33399) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10553:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4163:33399) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4163:33399) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(6523:9059:4163:33359) pci, pata_jmicron, STORAGE, JMB362/JMB363 Serial ATA Controller
:(6523:9059:4163:33359) pci, ahci, STORAGE, JMB362/JMB363 Serial ATA Controller
:(32902:10560:4163:33399) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:4163:33399) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4163:33399) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10548:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(4318:1553:6618:4160) pci, nvidia, VIDEO, ZT-88TES2P-FSP
:(32902:10570:4163:33399) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:(4545:22545:4163:33428) pci, firewire_ohci, FIREWIRE, IEEE 1394a Firewire Controller
:(4332:33127:4163:33293) pci, r8169, ETHERNET, RTL-8110SC/8169SC Gigabit Ethernet
:(32902:10552:4163:33399) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 36394904 34535489 34165798 9248768 9051522 9051522
:/dev/sdb1 /home ext4 4096 4096 120180148 83521290 77416471 30531584 30489389 30489389
:
Comment 1 Arthur 2012-08-26 04:16:18 EDT
In the wicd applet I checked the option to never connect to certain wireless networks.

Package: wicd-gtk-1.7.2.1-2.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 David Cantrell 2012-10-23 13:53:00 EDT
I am unable to reproduce the problem you are describing.  This is working fine for me on F-17 with wicd-gtk-1.7.2.1-2.fc17.

Note You need to log in before you can comment on or make changes to this bug.