Bug 850857 - [RHEVM][backend] [Host Networking] DC/CL 3.0 Save Network Configuration button is not enabled properly
[RHEVM][backend] [Host Networking] DC/CL 3.0 Save Network Configuration butto...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alona Kaplan
Martin Pavlik
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 10:43 EDT by Martin Pavlik
Modified: 2016-02-10 14:50 EST (History)
9 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log (4.85 KB, application/x-gzip)
2012-08-22 10:43 EDT, Martin Pavlik
no flags Details
screenshot 1 (256.42 KB, image/png)
2012-08-22 10:43 EDT, Martin Pavlik
no flags Details
screenshot 2 (235.00 KB, image/png)
2012-08-22 10:43 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-08-22 10:43:01 EDT
Created attachment 606295 [details]
vdsm.log + engine.log

Description of problem:
DC/CL 3.0 Save Network Configuration button is not enabled properly

for example: 
1) when network is attached/detached to to host NIC - > button is not enabled
2) if interface static IP is changed -> button is not enabeld 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: '3.1.0-13.el6ev' 
libvirt-0.9.10-21.el6_3.3.x86_64
qemu-img-rhev-0.12.1.2-2.295.el6.x86_64
vdsm-4.9-113.3.el6_3.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Add host to cluster 3.0
2. Create logical network
3. Hosts -> your host (in maintenance) -> Network interfaces -> some free NIC -> 
 add/edit -> Boot Protocol: static (fill in valid IP/mask) -> do NOT check Save network Configuration -> click OK  (see screenshots)

Actual results:
Save Network Configuration button is NOT enabled

Expected results:
Save Network Configuration button IS enabled

Additional info:


2012-08-22 16:40:04,089 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.AddNetworkVDSCommand] (ajp-/127.0.0.1:8009-2) [1eaccadb] START, AddNetworkVDSCommand(vdsId = 1a2c8c16-ec56-11e1-be74-001a4a013f0e, networkName=sw2, oldNetworkName=null, hostAddr=null, checkConnectivity=false, connectionTimeout=0, vlanId=null, bondName=null, nics=[em2], inetAddr=10.34.67.76, networkMask=255.255.255.224, gateway=, stp=false, bondingOptions=null, bootProtocol=StaticIp, vmNetwork=true), log id: 7aece7ab
Comment 1 Martin Pavlik 2012-08-22 10:43:19 EDT
Created attachment 606296 [details]
screenshot 1
Comment 2 Martin Pavlik 2012-08-22 10:43:38 EDT
Created attachment 606297 [details]
screenshot 2
Comment 3 Alona Kaplan 2012-08-26 10:23:36 EDT
The fix for Bug 838491 (upstream commit 4592e824cb323dadb7ba193fcf9d91d2e1db1221) fixed also this bug.
Comment 5 Martin Pavlik 2012-08-30 08:56:28 EDT
In SI16 bug reproduces, is the downstram commit included in SI16?
Comment 6 Alona Kaplan 2012-08-30 10:53:36 EDT
The gui bug was fixed.
The problem is with 3.0 hosts.
The "Save network configuration" is enabled according to the "NetConfigDirty" flag, reported by the vdsm.

In 3.0 hosts the flag was reported on vdsStats.
In 3.1 hosts the flag is reported on both vdsStats and vdsCaps.

It seems that the backend reads the flag from the vdsCaps- so there is no backward compatabily to 3.0 hosts.

martin- please check if it works for you on 3.1 host- configured on 3.0- dc and cluster.
Comment 7 Martin Pavlik 2012-08-31 02:55:03 EDT
(In reply to comment #6)
> The gui bug was fixed.
> The problem is with 3.0 hosts.
> The "Save network configuration" is enabled according to the
> "NetConfigDirty" flag, reported by the vdsm.
> 
> In 3.0 hosts the flag was reported on vdsStats.
> In 3.1 hosts the flag is reported on both vdsStats and vdsCaps.
> 
> It seems that the backend reads the flag from the vdsCaps- so there is no
> backward compatabily to 3.0 hosts.
> 
> martin- please check if it works for you on 3.1 host- configured on 3.0- dc
> and cluster.

Yes, this combination works.
Comment 8 Martin Pavlik 2012-08-31 03:13:08 EDT
After discussion with Alona, I am making this bug verified since GUI part of the problem was fixed. I opened a new bug for backend part of the issue https://bugzilla.redhat.com/show_bug.cgi?id=853340

Note You need to log in before you can comment on or make changes to this bug.