Bug 850881 - man page for rhn-migrate-classic-to-rhsm needs some updates for new/changed options
man page for rhn-migrate-classic-to-rhsm needs some updates for new/changed o...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Deon Ballard
Entitlement Bugs
: Documentation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-22 11:53 EDT by John Sefler
Modified: 2013-01-07 22:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-08-22 11:53:37 EDT
Description of problem:
Command line options for rhn-migrate-classic-to-rhsm have changed for RHEL 5.9 and now updates are needed to the man page.


Version-Release number of selected component (if applicable):
[root@jsefler-rhel59 ~]# man -P cat rhn-migrate-classic-to-rhsm | grep Version
Version 0.4                      July 18, 2012  rhn-migrate-classic-to-rhsm(8)
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.0.14-1.git.16.fec8200.el5


How reproducible:


Steps to Reproduce:

[root@jsefler-rhel59 ~]# rhn-migrate-classic-to-rhsm --help
Usage: rhn-migrate-classic-to-rhsm [OPTIONS]

options:
  -f, --force           Ignore channels not available on RHSM
  -g, --gui             Launch the GUI tool to subscribe the system, instead
                        of autosubscribing
  -n, --no-auto         Don't execute the autosubscribe option while
                        registering with subscription manager.
  -s SERVICELEVEL, --servicelevel=SERVICELEVEL
                        Service level to subscribe this system to. For no
                        service level use --service-level=""
  --serverurl=SERVERURL
                        Specify the Subscription Management Server to migrate
                        TO.
  -h, --help            show this help message and exit

Actual results:


CUT FROM CURRENT MAN PAGE...
OPTIONS
       -h, --help
              Prints the specific help information for the given command.

       -f, --force
              Ignore channels not available on Red Hat Network Subscription Management. The channels in Red Hat Network Classic are mapped to the product certificates used by Red Hat Network Subscription Management. However, not every channel has a certificate mapping, which can cause errors during migration.  Using  this  option  skips  any channels which are not mapped to Red Hat Network Subscription Management.

       -g, --gui
              Opens  the  Subscription Manager UI so that administrators can manually select which subscriptions to apply to the system. Without this option, the migration script automatically runs ’subscription-manager register --autosubscribe’ to register the system to Red Hat Network Subscription Management and  then  apply  all  relevant subscriptions.

^^^^^ THE SECOND SENTENCE ABOVE IS TOO MUCH INFO.  SUGGESTING THIS... At the end of the migration process, open the Subscription Manager UI so that an administrator can manually select which subscriptions to apply to the system instead of using the default autosubscribe mechanism.

       -n, --no-auto
              Unsubscribes  the system from Red Hat Network Classic but does not subsequently register the system to Red Hat Network Subscription Management or subscribe the system to any entitlements.

^^^^^ THIS --no-auto DESCRIPTION IS BAD AFTER FIXED BUG 849644 SEE IN-LINE HELP DESCRIPTION ABOVE

       -s SERVICE_LEVEL, --servicelevel=SERVICE_LEVEL
              Sets a preferred service level for the system, such as premium or standard. This service level preference is then used as one of the  criteria  for  autosubscribing the system.


^^^^^ MISSING AN EXPLATION FOR THE NEW --serverurl=SERVERURL OPTION
Comment 1 RHEL Product and Program Management 2012-08-22 11:58:08 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Deon Ballard 2012-09-06 01:06:43 EDT
Checked into master:
commit 0a98e047252194ec3c209fa01ffea32ea006038d
Comment 5 John Sefler 2012-09-14 16:00:24 EDT
Verifying Version...

[root@jsefler-rhel59 ~]# man -P cat rhn-migrate-classic-to-rhsm | grep Version
Version 0.5                    September 5, 2012rhn-migrate-classic-to-rhsm(8)
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.0.18-1.el5



rhn-migrate-classic-to-rhsm(8)                  rhn-migrate-classic-to-rhsm(8)



NAME
       rhn-migrate-classic-to-rhsm  -  Migrates  a system profile from Red Hat
       Network Classic  Hosted  to  Customer  Portal  Subscription  Management
       (hosted) or Subscription Asset Manager (on-premise).


SYNOPSIS
       rhn-migrate-classic-to-rhsm  [--force  |  --gui  |  --no-auto  | --ser-
       vicelevel=SERVICE_LEVEL | --serverurl=URL | --help]


DESCRIPTION
       rhn-migrate-classic-to-rhsm migrates a system profile which  is  regis-
       tered with Red Hat Network Classic to Customer Portal Subscription Man-
       agement. This is intended for migrating from the host service, not  for
       migrating from a Satellite system.


       This  script  migrates configuration, from a channel-based subscription
       framework to a certificate-based subscription framework. While the rhn-
       migrate-classic-to-rhsm  script  performs  the migration operation, the
       data used to map the channels to the corresponding product certificates
       is defined in the subscription-manager-migration-data package. The sub-
       scription-manager-migration-data package must be installed  before  the
       rhn-migrate-classic-to-rhsm script can be run successfully.


BACKGROUND
       Access  to  support and updates for products is determined through sub-
       scriptions.  Subscriptions are assigned to a system, which  means  that
       the system has the right to install and update a product with full sup-
       port. Subscriptions for an entire organization are  tracked  through  a
       subscription service.


       With  the  channel-based framework, a subscription service was either a
       local Satellite or hosted Red Hat Network Classic. With  the  new  cer-
       tificate-based  subscriptions,  the subscription service is either Cus-
       tomer Portal Subscription Management or Subscription Asset Manager. The
       differences   between  the  two  types  of  subscription  services  are
       described   in   this   Knowledgebase   article:   <https://access.red-
       hat.com/kb/docs/DOC-45987>


       The  system  registers  with  the  subscription service and receives an
       inventory ID number. When subscriptions are applied to a  system,  that
       association is noted in the subscription service.


       Registering  with  a  subscription service is exclusive. If a system is
       registered with Red Hat Network Classic, it  cannot  simultaneously  be
       registered  with  Customer  Portal  Subscription  Management.  The rhn-
       migrate-classic-to-rhsm tool is provided specifically so that there  is
       a way to transition from the deprecated Red Hat Network Classic to Cus-
       tomer Portal Subscription Management or a local Subscription Asset Man-
       ager.


OPTIONS
       -h, --help
              Prints the specific help information for the given command.


       -f, --force
              Ignore  channels not available through Customer Portal Subscrip-
              tion Management (or Subscription Asset Manager). The channels in
              Red  Hat  Network Classic are mapped to the product certificates
              used by the Customer Portal  Subscription  Management.  However,
              not  every  channel  has  a certificate mapping, which can cause
              errors during migration. Using this option  skips  any  channels
              which are not mapped to Customer Portal Subscription Management.


       -g, --gui
              Opens the Subscription Manager UI  so  that  administrators  can
              manually  select  which  subscriptions  to  apply  to the system
              rather than automatically  applying  best-matched  subscriptions
              based on the existing channel subscriptions.


       -n, --no-auto
              Unsubscribes  the system from Red Hat Network Classic and regis-
              ters it to Customer Portal Subscription Management, but does not
              subscribe the system to any entitlements.


       -s SERVICE_LEVEL, --servicelevel=SERVICE_LEVEL
              Sets  a  preferred service level for the system, such as premium
              or standard. This service level preference is then used  as  one
              of the criteria for autosubscribing the system.


       --serverurl=URL
              Gives the URL of the subscription management service to which to
              register the system. This is used for environments which have an
              on-premise  subscription service such as Subscription Asset Man-
              ager. If no URL is given, the migration tool uses  the  Customer
              Portal Subscription Management Service.


USAGE
       The  migration  process moves the system from the inventory in one sub-
       scription service (Red Hat Network Classic)  to  the  new  subscription
       service  (Customer Portal Subscription Management), and then re-applies
       the subscriptions to the system. The script runs through these steps:


              1. Authenticate to both Red Hat  Network  Classic  and  Customer
              Portal Subscription Management to verify the account settings.


              2. Get a channel list for the system.


              3. Match each channel to a corresponding certificate map.


              4. Copy over the product certificates for the old channels.


              5. Unregister from Red Hat Network Classic.


              6.  Register  with  Customer  Portal Subscription Management and
              auto-subscribe  to  the  best-matched  subscriptions.  (Alterna-
              tively,  the --gui option can be used to launch the Subscription
              Manager UI to assign subscriptions manually.)


       After migration, the system facts maintained  by  Subscription  Manager
       display what script was used for migration and what the previous system
       ID was.
       [root@server ~]# subscription-manager facts --list | grep migr
       migration.classic_system_id: 09876
       migration.migrated_from: rhn_hosted_classic


   MIGRATION AND AUTOSUBSCRIBE
       The rhn-migrate-classic-to-rhsm tool, by  default,  autosubscribes  the
       system to the best-matching subscriptions. This allows migrations to be
       automated.

       [root@server ~]# rhn-migrate-classic-to-rhsm
       RHN Username: jsmith@example.com
       Password:

       Retrieving existing RHN classic subscription information ...
       +----------------------------------+
       System is currently subscribed to:
       +----------------------------------+
       rhel-i386-client-5

       List of channels for which certs are being copied
       rhel-i386-client-5

       Product Certificates copied successfully to /etc/pki/product !!

       Preparing to unregister system from RHN classic ...
       System successfully unregistered from RHN Classic.

       Attempting to register system to RHN ...
       The system has been registered with id: abcd1234
       System ’server.example.com’ successfully registered to RHN.

       Attempting to auto-subscribe to appropriate subscriptions ...
       Installed Product Current Status:
       ProductName:            Red Hat Enterprise Linux Desktop
       Status:                 Subscribed

       Successfully subscribed.

       Please visit https://access.redhat.com/management/consumers/abcd1234 to view the details, and to make changes if necessary.


       The script prompts for a username and password to use to  register  the
       system;  this  same  account  is used to authenticate with both Red Hat
       Network Classic and Customer Portal Subscription Management.


       Optionally, the --servicelevel argument sets an SLA preference  to  use
       with  the system. The SLA associated with a subscription is then evalu-
       ated when determining what subscriptions to  autosubscribe  the  system
       to,  along with other factors like installed products, existing channel
       assignments, and architecture.

       [root@server ~]# rhn-migrate-classic-to-rhsm --servicelevel=premium
       RHN Username: jsmith@example.com
       Password:



   MIGRATION TO ON-PREMISE SERVICES
       The rhn-migrate-classic-to-rhsm tool migrates the  system  to  Customer
       Portal  Subscription Management (hosted) services by default. This uses
       the default configuration for Subscription Manager. For infrastructures
       which  have  an on-premise subscription management service such as Sub-
       scription Asset Manager, the .

       [root@server ~]# rhn-migrate-classic-to-rhsm
       RHN Username: jsmith@example.com
       Password:


   MIGRATION AND MANUALLY SELECTING SUBSCRIPTIONS
       The --no-auto option prevents  the  autosubscribe  step  from  running,
       while  the  --gui  option  opens  the  Subscription Manager GUI so that
       administrators can assign subscriptions to  the  system.  As  with  the
       autosubscribe  process,  the  script  prompts  for the RHN username and
       password for the user.

       [root@server ~]# rhn-migrate-classic-to-rhsm --gui --no-auto
       RHN Username: jsmith@example.com
       Password:

       Retrieving existing RHN classic subscription information ...
       +----------------------------------+
       System is currently subscribed to:
       +----------------------------------+
       rhel-i386-client-5

       List of channels for which certs are being copied
       rhel-i386-client-5

       Product Certificates copied successfully to /etc/pki/product !!

       Preparing to unregister system from RHN classic ...
       System successfully unregistered from RHN Classic.

       Attempting to register system to RHN ...
       The system has been registered with id: abcd1234
       System server.example.com successfully registered to RHN.

       Launching the GUI tool to manually subscribe the system ...


   UNREGISTER FROM RED HAT NETWORK CLASSIC ONLY
       The rhn-migrate-classic-to-rhsm tool can be used simply to unregister a
       system  from Red Hat Network Classic without registering it to Customer
       Portal Subscription Management or assigning subscriptions to  the  sys-
       tem.

       [root@server ~]# rhn-migrate-classic-to-rhsm --no-auto
       RHN Username: jsmith@example.com
       Password:

       Retrieving existing RHN classic subscription information ...
       +----------------------------------+
       System is currently subscribed to:
       +----------------------------------+
       rhel-i386-client-5

       List of channels for which certs are being copied
       rhel-i386-client-5

       Product Certificates copied successfully to /etc/pki/product !!

       Preparing to unregister system from RHN classic ...
       System successfully unregistered from RHN Classic.



FILES
       /etc/sysconfig/rhn/systemid
              The  digital  server  ID for this machine if the system has been
              registered with Red Hat Network Classic.   This  file  does  not
              exist otherwise.


       /etc/sysconfig/rhn/up2date
              The common configuration file used by RHN client programs.


       /var/log/rhsm/rhsm.log
              The Subscription Manager log file. This contains any errors reg-
              istering the system to Customer Portal  Subscription  Management
              or with subscribing the system to entitlements.


       /etc/rhsm/facts/migration.facts
              The  file which contains the migration information. This is dis-
              played as one of the system facts by Subscription Manager.


       subscription-manager-migration-data.rpm
              The package which contains the mappings for the migration script
              to migrate channels to the appropriate product certificates.


SEE ALSO
       install-num-migrate-to-rhsm(8), subscription-manager(8).



AUTHORS
       Paresh  Mutha  <pmutha@redhat.com>, Mark Huth <mhuth@redhat.com>, Tasos
       Papaioannou <tpapaioa@redhat.com>


BUGS
       Report bugs to <http://bugzilla.redhat.com>.


COPYRIGHT
       Copyright © 2012 Red Hat, Inc.


       This is free software; see the source for copying conditions.  There is
       NO  warranty;  not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
       PURPOSE.



Version 0.5                    September 5, 2012rhn-migrate-classic-to-rhsm(8)



___________________________________________________________________________

In the man page above, corrections have been made, unfortunately there are more that are needed:

1. In the "After migration, the system facts maintained..." section, we have added a new migration.migration_date fact.
[root@server ~]# subscription-manager facts --list | grep migr
migration.classic_system_id: 1023065782
migration.migrated_from: rhn_hosted_classic
migration.migration_date: 2012-09-14T14:55:29.280519

2. There is an extraneous block of example code directly before the "MIGRATION TO ON-PREMISE SERVICES" section.

3. The "MIGRATION TO ON-PREMISE SERVICES" looks unfinished.

4. In the "MIGRATION AND MANUALLY SELECTING SUBSCRIPTIONS" section, specifying the --gui option implies --no-auto, therefore there is no need to specify both arguments --gui --no-auto in the example.  Specifying --gui is sufficient for this section.

5. The "UNREGISTER FROM RED HAT NETWORK CLASSIC ONLY" section is no longer true.  I would remove this section entirely.  This tool will unregister the system from classic and it will register the system to a ceterificate based subscription management service.  There will simply be no attempt to consume subscriptions when using the --no-auto option.

6. In the FILES section, /etc/rhsm/facts/migration.facts is not real.  This file is the artifact of a brilliant test case.  I would completely remove all doc references to this file.

7. No big deal, but I will point out that the messages spit out by the tool have slightly changed for rhel59 thereby making the code examples in the man page out-dated.

8. The AUTHORS section is missing Deon Lackey.


Moving back to ASSIGNED.
Comment 6 Deon Ballard 2012-09-19 22:19:02 EDT
I hit everything but #7, the output. I'm checking out a beaker machine to try to get that output, but I'm switching this to ON_QA just so it can get into a build and verified (even with old output examples).

commit:
b8fdc69a39359f18d165c9309715bb8ad567cce5
Comment 7 John Sefler 2012-10-05 11:37:20 EDT
Verifying Version...

[root@jsefler-rhel59 ~]# man -P cat rhn-migrate-classic-to-rhsm | grep Version
Version 0.5                    September 5, 2012rhn-migrate-classic-to-rhsm(8)
[root@jsefler-rhel59 ~]# rpm -q subscription-manager-migration
subscription-manager-migration-1.0.21-1.el5



[root@jsefler-rhel59 ~]# man -P cat rhn-migrate-classic-to-rhsm
rhn-migrate-classic-to-rhsm(8)                  rhn-migrate-classic-to-rhsm(8)



NAME
       rhn-migrate-classic-to-rhsm - Migrates a system profile from Red
       Hat Network Classic Hosted to Customer Portal Subscription  Man-
       agement (hosted) or Subscription Asset Manager (on-premise).


SYNOPSIS
       rhn-migrate-classic-to-rhsm  [--force  |  --gui  |  --no-auto  |
       --servicelevel=SERVICE_LEVEL | --serverurl=URL | --help]


DESCRIPTION
       rhn-migrate-classic-to-rhsm migrates a system profile  which  is
       registered  with Red Hat Network Classic to Customer Portal Sub-
       scription Management. This is intended for  migrating  from  the
       host service, not for migrating from a Satellite system.


       This  script  migrates  configuration, from a channel-based sub-
       scription framework to a certificate-based  subscription  frame-
       work.  While the rhn-migrate-classic-to-rhsm script performs the
       migration operation, the data used to map the  channels  to  the
       corresponding  product  certificates is defined in the subscrip-
       tion-manager-migration-data package.  The  subscription-manager-
       migration-data package must be installed before the rhn-migrate-
       classic-to-rhsm script can be run successfully.


BACKGROUND
       Access to support and updates for products is determined through
       subscriptions.   Subscriptions  are  assigned to a system, which
       means that the system has the right  to  install  and  update  a
       product with full support. Subscriptions for an entire organiza-
       tion are tracked through a subscription service.


       With the channel-based framework,  a  subscription  service  was
       either a local Satellite or hosted Red Hat Network Classic. With
       the new certificate-based subscriptions, the  subscription  ser-
       vice  is  either Customer Portal Subscription Management or Sub-
       scription Asset Manager. The differences between the  two  types
       of  subscription  services  are  described in this Knowledgebase
       article: <https://access.redhat.com/kb/docs/DOC-45987>


       The system registers with the subscription service and  receives
       an inventory ID number. When subscriptions are applied to a sys-
       tem, that association is noted in the subscription service.


       Registering with a subscription service is exclusive. If a  sys-
       tem is registered with Red Hat Network Classic, it cannot simul-
       taneously be registered with Customer Portal  Subscription  Man-
       agement.   The   rhn-migrate-classic-to-rhsm  tool  is  provided
       specifically so that there is a way to transition from the  dep-
       recated  Red Hat Network Classic to Customer Portal Subscription
       Management or a local Subscription Asset Manager.


OPTIONS
       -h, --help
              Prints the specific help information for the  given  com-
              mand.


       -f, --force
              Ignore  channels  not  available  through Customer Portal
              Subscription Management (or Subscription Asset  Manager).
              The channels in Red Hat Network Classic are mapped to the
              product certificates used by  the  Customer  Portal  Sub-
              scription  Management.  However,  not every channel has a
              certificate mapping, which can cause errors during migra-
              tion.  Using this option skips any channels which are not
              mapped to Customer Portal Subscription Management.


       -g, --gui
              Opens the Subscription Manager UI so that  administrators
              can  manually  select which subscriptions to apply to the
              system rather than  automatically  applying  best-matched
              subscriptions  based  on  the  existing channel subscrip-
              tions.


       -n, --no-auto
              Unsubscribes the system from Red Hat Network Classic  and
              registers  it to Customer Portal Subscription Management,
              but does not subscribe the system to any subscriptions.


       -s SERVICE_LEVEL, --servicelevel=SERVICE_LEVEL
              Sets a preferred service level for the  system,  such  as
              premium  or  standard.  This  service level preference is
              then used as one of the criteria for autosubscribing  the
              system.


       --serverurl=URL
              Gives  the  URL of the subscription management service to
              which to register the system. This is used  for  environ-
              ments  which have an on-premise subscription service such
              as Subscription Asset Manager. If no URL  is  given,  the
              migration tool uses the Customer Portal Subscription Man-
              agement Service.


USAGE
       The migration process moves the system from the inventory in one
       subscription  service  (Red Hat Network Classic) to the new sub-
       scription service (Customer Portal Subscription Management), and
       then re-applies the subscriptions to the system. The script runs
       through these steps:


              1. Authenticate to both Red Hat Network Classic and  Cus-
              tomer   Portal  Subscription  Management  to  verify  the
              account settings.


              2. Get a channel list for the system.


              3. Match each channel to a corresponding certificate map.


              4.  Copy  over the product certificates for the old chan-
              nels.


              5. Unregister from Red Hat Network Classic.


              6. Register with Customer Portal Subscription  Management
              and  auto-subscribe  to  the  best-matched subscriptions.
              (Alternatively, the --gui option can be  used  to  launch
              the Subscription Manager UI to assign subscriptions manu-
              ally.)


       After migration, the system  facts  maintained  by  Subscription
       Manager  display what script was used for migration and what the
       previous system ID was.
       [root@server ~]# subscription-manager facts --list | grep migr
       migration.classic_system_id: 09876
       migration.migrated_from: rhn_hosted_classic
       migration.migration_date: 2012-09-14T14:55:29.280519



   MIGRATION AND AUTOSUBSCRIBE
       The rhn-migrate-classic-to-rhsm tool, by default, autosubscribes
       the  system  to  the  best-matching  subscriptions.  This allows
       migrations to be automated.

       [root@server ~]# rhn-migrate-classic-to-rhsm
       RHN Username: jsmith@example.com
       Password:

       Retrieving existing RHN classic subscription information ...
       +----------------------------------+
       System is currently subscribed to:
       +----------------------------------+
       rhel-i386-client-5

       List of channels for which certs are being copied
       rhel-i386-client-5

       Product Certificates copied successfully to /etc/pki/product !!

       Preparing to unregister system from RHN classic ...
       System successfully unregistered from RHN Classic.

       Attempting to register system to RHN ...
       The system has been registered with id: abcd1234
       System ’server.example.com’ successfully registered to RHN.

       Attempting to auto-subscribe to appropriate subscriptions ...
       Installed Product Current Status:
       ProductName:            Red Hat Enterprise Linux Desktop
       Status:                 Subscribed

       Successfully subscribed.

       Please visit https://access.redhat.com/management/consumers/abcd1234 to view the details, and to make changes if necessary.


       The script prompts for a username and password to use to  regis-
       ter  the  system; this same account is used to authenticate with
       both Red Hat Network Classic and  Customer  Portal  Subscription
       Management.


       Optionally,  the  --servicelevel argument sets an SLA preference
       to use with the system. The SLA associated with  a  subscription
       is  then  evaluated when determining what subscriptions to auto-
       subscribe the system to, along with other factors like installed
       products, existing channel assignments, and architecture.

       [root@server ~]# rhn-migrate-classic-to-rhsm --servicelevel=premium
       RHN Username: jsmith@example.com
       Password:


   MIGRATION TO ON-PREMISE SERVICES
       The rhn-migrate-classic-to-rhsm tool migrates the system to Cus-
       tomer  Portal  Subscription  Management  (hosted)  services   by
       default.  This  uses  the default configuration for Subscription
       Manager, which points to the subscription services for the  Cus-
       tomer  Portal. For infrastructures which have an on-premise sub-
       scription management service such as Subscription Asset Manager,
       this  configuration can be changed so that the migration process
       registers and subscribes the systems to the on-premise subscrip-
       tion services.


       This  is  done  by using the --serverurl option, which specifies
       the URL of the local service. In this  case,  the  authorization
       credentials  must  also be given for the local subscription man-
       agement  service  account  (which  is  independent  of  the  RHN
       account).

       [root@server ~]# rhn-migrate-classic-to-rhsm --serverurl=sam.example.com
       Username: jsmith@example.com
       Password:


   MIGRATION AND MANUALLY SELECTING SUBSCRIPTIONS
       The  --no-auto  option prevents the autosubscribe step from run-
       ning. The --gui option not only prevents autosubscribe from run-
       ning,  it  automatically  opens  the Subscription Manager GUI so
       that administrators can assign subscriptions to the system.


       As with the autosubscribe process, the script  prompts  for  the
       RHN username and password for the user.

       [root@server ~]# rhn-migrate-classic-to-rhsm --gui
       RHN Username: jsmith@example.com
       Password:

       Retrieving existing RHN classic subscription information ...
       +----------------------------------+
       System is currently subscribed to:
       +----------------------------------+
       rhel-i386-client-5

       List of channels for which certs are being copied
       rhel-i386-client-5

       Product Certificates copied successfully to /etc/pki/product !!

       Preparing to unregister system from RHN classic ...
       System successfully unregistered from RHN Classic.

       Attempting to register system to RHN ...
       The system has been registered with id: abcd1234
       System server.example.com successfully registered to RHN.

       Launching the GUI tool to manually subscribe the system ...


FILES
       /etc/sysconfig/rhn/systemid
              The  digital server ID for this machine if the system has
              been registered with Red Hat Network Classic.  This  file
              does not exist otherwise.


       /etc/sysconfig/rhn/up2date
              The  common  configuration  file  used by RHN client pro-
              grams.


       /var/log/rhsm/rhsm.log
              The Subscription Manager  log  file.  This  contains  any
              errors  registering  the  system  to Customer Portal Sub-
              scription Management or with subscribing  the  system  to
              subscriptions.


       subscription-manager-migration-data.rpm
              The package which contains the mappings for the migration
              script to migrate channels  to  the  appropriate  product
              certificates.


SEE ALSO
       install-num-migrate-to-rhsm(8), subscription-manager(8).



AUTHORS
       Deon  Lackey  <dlackey@redhat.com>,  Paresh  Mutha  <pmutha@red-
       hat.com>, Mark Huth <mhuth@redhat.com>, Tasos Papaioannou  <tpa-
       paioa@redhat.com>


BUGS
       Report bugs to <http://bugzilla.redhat.com>.


COPYRIGHT
       Copyright © 2012 Red Hat, Inc.


       This  is  free  software; see the source for copying conditions.
       There is NO warranty; not even for  MERCHANTABILITY  or  FITNESS
       FOR A PARTICULAR PURPOSE.



Version 0.5                    September 5, 2012rhn-migrate-classic-to-rhsm(8)



___________________________________________________________________________

issue 1 in comment 5: fix verified
issue 2 in comment 5: not a bug; code snippet demonstrates use of --servicelevel
issue 3 in comment 5: fix verified
issue 4 in comment 5: fix verified
issue 5 in comment 5: fix verified
issue 6 in comment 5: fix verified
issue 7 in comment 5: issue still applies, but is not serious and should not affect user's understanding of rhn-migrate-classic-to-rhsm
issue 8 in comment 5: fix verified


Moving to VERIFIED
Comment 9 errata-xmlrpc 2013-01-07 22:59:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.