Bug 850902 - category create fails
category create fails
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jay Dobies
Preethi Thomas
: Triaged
Depends On: 850863
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 12:58 EDT by Preethi Thomas
Modified: 2013-09-09 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 850863
Environment:
Last Closed: 2013-01-09 12:07:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-08-22 12:58:56 EDT
clone for master

+++ This bug was initially created as a clone of Bug #850863 +++

Description of problem:

repo uploads category fails to create.

Version-Release number of selected component (if applicable):

[root@pulp-candidate scripts]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.1-1.fc17.noarch
How reproducible:


Steps to Reproduce:
1. create a repo 
2. try to create a create a category
3.
  
Actual results:
[root@pulp-candidate scripts]# pulp-admin repo uploads category  create --repo-id pulp --category-id "pulp-category"  --name "pulp"  --description "pulp"
An unexpected error has occurred. More information can be found in the client
log file ~/.pulp/admin.log.



Expected results:

Category successully created.

Additional info:

2012-08-22 10:51:31,969 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 475, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 891, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 184, in execute
    return self.method(*arg_list, **clean_kwargs)
TypeError: create() takes exactly 1 argument (9 given)
2012-08-22 10:54:53,932 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/client/extensions/core.py", line 475, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 891, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/usr/lib/python2.7/site-packages/okaara/cli.py", line 184, in execute
    return self.method(*arg_list, **clean_kwargs)
TypeError: create() takes exactly 1 argument (9 given)

--- Additional comment from jason.dobies@redhat.com on 2012-08-22 11:07:22 EDT ---

This looks like the issue we've seen previously when extra stuff is passed to the argument and okaara assumes it was intentional, but it's not exactly the same. I'll take a look at the two together.
Comment 1 Jay Dobies 2012-09-04 15:22:18 EDT
commit 951d8954552723b95d938c9535a1ae02e3f89924
Author: Jay Dobies <jason.dobies@redhat.com>
Date:   Tue Sep 4 14:23:51 2012 -0400

    Cleaned up code

commit f9f67b6b6d87311b9fd1d5cb0d42a192cad2552e
Author: Jay Dobies <jason.dobies@redhat.com>
Date:   Tue Sep 4 13:45:56 2012 -0400

    850863 - Print usage if a non-kwarg is specified
Comment 2 Jeff Ortel 2012-09-11 09:31:27 EDT
build: 0.327
Comment 3 Preethi Thomas 2012-09-27 08:37:09 EDT
[root@pulp-master ~]# rpm -q pulp-rpm-server
pulp-rpm-server-0.0.328-1.fc17.noarch
[root@pulp-master ~]# 

[root@pulp-master ~]# pulp-admin repo uploads category  create --repo-id pulp --category-id "pulp-category"  --name "pulp"  --description "pulp"
Command: category
Description: creates a new package category

Available Arguments:

  --repo-id         - (required) unique identifier; only alphanumeric, -, and _
                      allowed
  -v                - display extra information about the upload process
  --category-id, -i - (required) id of the package category
  --name, -n        - (required) name of the package category
  --description, -d - (required) description of the package category
  --display-order   - display order for the package category
  --group, -g       - package group IDs to include in the package category;
                      multiple may be indicated by specifying the argument
                      multiple times
[root@pulp-master ~]# 
[root@pulp-master ~]# 
[root@pulp-master ~]# pulp-admin repo uploads category  --repo-id pulp --category-id "pulp-category"  --name "pulp"  --description "pulp"
+----------------------------------------------------------------------+
                          Puppet Module Upload
+----------------------------------------------------------------------+

Extracting necessary metdata for each request...
... completed

Creating upload requests on the server...
[==================================================] 100%
Initializing upload
... completed

Starting upload of selected packages. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Importing into the repository...
... completed

Deleting the upload request...
... completed

[root@pulp-master ~]#
Comment 4 Preethi Thomas 2013-01-09 12:07:43 EST
Pulp v2.0 released

Note You need to log in before you can comment on or make changes to this bug.