This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 850917 - Dictionary data structure improvements for better performance.
Dictionary data structure improvements for better performance.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Ric Wheeler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-22 14:04 EDT by Amar Tumballi
Modified: 2014-04-17 07:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:39:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2012-08-22 14:04:34 EDT
Description of problem:
Current dictionary implementation in glusterfs is very memory allocation intensive and we need to get it better in terms to achieve better performance as it is a regularly used data structure in the process.

Version-Release number of selected component (if applicable): master/upstream

Additional info: this is an enhancement effort
Comment 1 Amar Tumballi 2012-10-11 09:14:36 EDT
http://review.gluster.org/3910
Comment 2 Anand Avati 2013-09-11 08:34:11 EDT
REVIEW: http://review.gluster.org/4035 (core: add 'dict' stat collection logic) posted (#2) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 3 Anand Avati 2013-09-11 08:34:44 EDT
REVIEW: http://review.gluster.org/3910 (dict: data structure changes and cleanup) posted (#5) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 4 Anand Avati 2013-09-22 02:44:08 EDT
REVIEW: http://review.gluster.org/5974 (core: make sure dict_get_str doesn't return a malformed string) posted (#4) for review on master by Anand Avati (avati@redhat.com)
Comment 5 Anand Avati 2013-12-06 01:59:32 EST
REVIEW: http://review.gluster.org/4035 (core: add 'dict' stat collection logic) posted (#5) for review on master by Amar Tumballi (amarts@gmail.com)
Comment 6 Anand Avati 2013-12-06 01:59:39 EST
REVIEW: http://review.gluster.org/3910 (dict: data structure changes and cleanup) posted (#8) for review on master by Amar Tumballi (amarts@gmail.com)
Comment 7 Anand Avati 2013-12-06 01:59:48 EST
REVIEW: http://review.gluster.org/6449 (dict: remove all the reference to get_new_dict()) posted (#1) for review on master by Amar Tumballi (amarts@gmail.com)
Comment 11 Niels de Vos 2014-04-17 07:39:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.