Bug 851003 - ovirt-engine-backend: StoragePool storage_pool_format_type is null after upgrade (lost in update)
ovirt-engine-backend: StoragePool storage_pool_format_type is null after upgr...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
storage
: TestBlocker
Depends On: 845310
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 01:06 EDT by Ayal Baron
Modified: 2016-02-10 14:09 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 845310
Environment:
Last Closed: 2012-10-02 07:38:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Asaf Shakarchi 2012-10-02 07:38:02 EDT
The 'format type' column in the pools table is not changed to null during DC updates, 

This is because the property on the business entity was added only in 3.1,


Thus the upgrade script is unnecessary as the pool always has a format type value after attaching the first domain.

Closing.

Note You need to log in before you can comment on or make changes to this bug.