Bug 851094 - No snapshot is selected by default when opening Snapshots tab in VM
No snapshot is selected by default when opening Snapshots tab in VM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Daniel Erez
Dafna Ron
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 04:49 EDT by Tomas Dosek
Modified: 2016-02-10 13:50 EST (History)
10 users (show)

See Also:
Fixed In Version: SI20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:00:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snapshot (79.81 KB, image/png)
2012-08-23 04:49 EDT, Tomas Dosek
no flags Details

  None (edit)
Description Tomas Dosek 2012-08-23 04:49:57 EDT
Created attachment 606476 [details]
Snapshot

Description of problem:
Snapshot information is not loaded into info window. Please see attached screenshot.

Version-Release number of selected component (if applicable):
si15

How reproducible:
100 %

Steps to Reproduce:
1.Create a snapshot
2.Click on it
3.Check the info window (on the right from snapshot list)
  
Actual results:
Info is not showed

Expected results:
Info should be showed

Additional info:
Attaching screenshot
Comment 1 Allon Mureinik 2012-08-26 04:47:37 EDT
Works on my env with commit hash d3e2a8146baae3fa01d3c2edcf1aea4fbb4de3ae, both on webadmin and user portal.
(Note that current snapshot info is never shown).

Steps that worked:
1. create VM, no OS, with a network interface and one nic
2. create a snapshot
3. check the info window - details are show.

Please supply exact steps how to reproduce, and attach all relevant logs.
Comment 2 Haim 2012-08-26 05:15:46 EDT
check again (reproduced on SI15 on both webadmin and userportal):

Steps that worked:
1. create VM, no OS, with a network interface and one nic
2. create a snapshot
3. check the general tab - its empty

I suspect its a refresh issue in web-admin since if I hit "virtual disks" sub-tab and move back to "general" i get the snapshot info,
Comment 3 Allon Mureinik 2012-08-26 08:06:27 EDT
Daniel, can you please take a look?
Comment 4 vvyazmin@redhat.com 2012-08-30 04:33:34 EDT
Works for me ... Verified on RHEVM 3.1 - SI15.1

RHEVM: rhevm-3.1.0-13.el6ev.noarch
VDSM: vdsm-4.9.6-30.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.298.el6_3.x86_64
SANLOCK: sanlock-2.3-3.el6_3.x86_64
Comment 5 Daniel Erez 2012-09-27 20:27:46 EDT
patch sent upstream:
http://gerrit.ovirt.org/#/c/8260/
Comment 6 Allon Mureinik 2012-09-30 07:59:22 EDT
Merged Id09884a06615ecd2c1fdf7128f7af684a7e70a7d
Comment 7 Dafna Ron 2012-10-14 08:59:25 EDT
verified on clean si20 install

Note You need to log in before you can comment on or make changes to this bug.