Bug 851119 - yum's traceback while creating servicepack
yum's traceback while creating servicepack
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: PackageKit (Show other bugs)
7.0
All Linux
unspecified Severity medium
: beta
: 7.0
Assigned To: Richard Hughes
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 06:03 EDT by Vladimir Benes
Modified: 2014-06-13 06:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: PackageKit-0.8.9-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:31:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2012-08-23 06:03:08 EDT
Description of problem:

$ pkgenpack -p kernel
Finding package name.
More than one package matches:
1. kernel-3.3.0-0.20.el7.x86_64 [installed:repos_Workstation]
2. kernel-3.5.0-0.24.el7.x86_64 [repos_Workstation]
Please choose the correct package: 2
Creating service pack...
Getting dependencies[=========================]         
Unknown role type   [=========================]         
Waiting in queue    [=========================]         
Starting            [=========================]         
Getting information [=========================]         
Failed to create '/root/kernel-.servicepack': Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1467, in _get_best_depends
    results = self.yumbase.findDeps(pkgs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2799, in findDeps
    for po in self.whatProvides(r, f, v):
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 220, in whatProvides
    defSack = ListPackageSack(self.pkgSack.searchProvides((name, flags, version)))
  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 427, in searchProvides
    return self._computeAggregateListResult("searchProvides", name)
  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 600, in _computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 1403, in searchProvides
    ret = self.searchPrco(name, "provides")
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 1389, in searchPrco
    results.extend(self._search_primary_files(n))
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 862, in _search_primary_files
    self._sql_pkgKey2po(rep, cur, results)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 834, in _sql_pkgKey2po
    pkg = self._packageByKey(repo, ob['pkgKey'])
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 744, in _packageByKey
    elif exclude and self._pkgExcluded(self._key2pkg[repo][pkgKey]):
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 677, in _pkgExcluded
    return self._pkgExcludedRKT(po.repo, po.pkgKey, po.pkgtup)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 665, in _pkgExcludedRKT
    return self._pkgExcludedRKNEVRA(repo, pkgKey, n,e,v,r,a)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 607, in _pkgExcludedRKNEVRA
    if self._pkgKeyExcluded(repo, pkgKey):
RuntimeError: maximum recursion depth exceeded


Version-Release number of selected component (if applicable):
PackageKit-0.7.4-5.el7.x86_64
Comment 1 Richard Hughes 2012-11-29 06:35:35 EST
This works for me when using PackageKit-0.8.6-1.el7 -- can you retest using that please. Thanks!
Comment 2 Vladimir Benes 2012-11-29 07:33:31 EST
still the same

pkgenpack -p mc
Finding package name.
More than one package matches:
1. mc-1:4.8.6-1.el7.x86_64 [installed:rhel7]
2. mc-1:4.8.6-1.el7.i686 [rhel7-opt-eng]
Please choose the correct package: 2
Creating service pack...
Getting dependencies[=========================]         
Waiting in queue    [=========================]         
Starting            [=========================]         
Getting information [=========================]         
Failed to create '/home/vbenes/mc-.servicepack': Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1466, in _get_best_depends
    results = self.yumbase.findDeps(pkgs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2863, in findDeps
    for po in self.whatProvides(r, f, v):
  File "/usr/lib/python2.7/site-packages/yum/depsolve.py", line 220, in whatProvides
    defSack = ListPackageSack(self.pkgSack.searchProvides((name, flags, version)))
  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 422, in searchProvides
    return self._computeAggregateListResult("searchProvides", name)
  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 595, in _computeAggregateListResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 1403, in searchProvides
    ret = self.searchPrco(name, "provides")
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 1389, in searchPrco
    results.extend(self._search_primary_files(n))
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 862, in _search_primary_files
    self._sql_pkgKey2po(rep, cur, results)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 834, in _sql_pkgKey2po
    pkg = self._packageByKey(repo, ob['pkgKey'])
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 744, in _packageByKey
    elif exclude and self._pkgExcluded(self._key2pkg[repo][pkgKey]):
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 677, in _pkgExcluded
    return self._pkgExcludedRKT(po.repo, po.pkgKey, po.pkgtup)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 665, in _pkgExcludedRKT
    return self._pkgExcludedRKNEVRA(repo, pkgKey, n,e,v,r,a)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 607, in _pkgExcludedRKNEVRA
    if self._pkgKeyExcluded(repo, pkgKey):
RuntimeError: maximum recursion depth exceeded
Comment 3 Vladimir Benes 2012-11-29 07:33:58 EST
PackageKit-0.8.6-1.fc18.x86_64
Comment 4 Richard Hughes 2013-05-07 15:54:41 EDT
I think this will fix it:

commit 316a5b9f4c3636d808cf46fae3531cadfc91e4ce
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue May 7 16:24:12 2013 +0100

    Support getting the distro-id from /etc/os-release
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=851149

:100644 100644 a9ef87f... 12f18cd... M  lib/packagekit-glib2/pk-common.c
:100644 100644 0822f5f... 688daf8... M  lib/packagekit-glib2/pk-self-test.c
Comment 5 smatula 2013-11-20 16:02:30 EST
Fix Verified with Build RHEL-7.0-20131115.2 x86_64 PackageKit-0.8.9-8.el7

pkgenpack -p kernel successful in creating .servicepack when update needed.
No error generated. Install of .servicepack was successful.
Comment 6 Ludek Smid 2014-06-13 06:31:40 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.