Bug 851124 - Unable to unsubscribe in GUI
Unable to unsubscribe in GUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Devan Goodwin
Entitlement Bugs
: QA-Closed
: 854916 (view as bug list)
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-08-23 06:09 EDT by Shwetha Kallesh
Modified: 2013-01-07 22:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:59:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-08-23 06:09:00 EDT
Description of problem:

Not able to unsubscribe from GUI
Version-Release number of selected component (if applicable):

[root@dhcp201-196 product]# rpm -qa | grep subscription-manager
subscription-manager-gui-1.0.14-1.git.10.4cd750a.el5
subscription-manager-migration-1.0.14-1.git.10.4cd750a.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-firstboot-1.0.14-1.git.10.4cd750a.el5
subscription-manager-1.0.14-1.git.10.4cd750a.el5

How reproducible:


Steps to Reproduce:
1.[root@dhcp201-115 ~]# subscription-manager-gui
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
[root@dhcp201-115 ~]# subscription-manager-gui
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'

2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2012-08-24 05:38:12 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-08-29 12:19:34 EDT
Can not reproduce:

[root@bkearney ~]# subscription-manager-gui 
[root@bkearney ~]# rpm -qa | grep python-rhsm
python-rhsm-1.0.5-1.git.1.1ce0910.fc17.x86_64
[root@bkearney ~]# rpm -qa | grep subscription
subscription-manager-gui-1.0.14-1.git.27.c389edc.fc17.x86_64
subscription-manager-1.0.14-1.git.27.c389edc.fc17.x86_64
[root@bkearney ~]# subscription-manager register --auto
Username: rhn-cservice-acarter
Password: 
The system has been registered with id: 775f27bf-fb0e-4a1d-a436-c3d3d42470ea 
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

[root@bkearney ~]# subscription-manager-gui
Comment 3 Shwetha Kallesh 2012-08-30 04:56:57 EDT
I can still reproduce that 

[root@dhcp201-115 ~]# subscription-manager-gui
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'

[root@dhcp201-115 ~]# tail -f /var/log/rhsm/rhsm.log
2012-08-30 10:40:10,692 [DEBUG]  @connection.py:357 - Response status: 200
2012-08-30 10:40:10,693 [DEBUG]  @managerlib.py:493 - found 39 pools:
2012-08-30 10:40:10,694 [DEBUG]  @managerlib.py:494 -    25 compatible
2012-08-30 10:40:10,694 [DEBUG]  @managerlib.py:495 -    14 incompatible
2012-08-30 10:40:10,695 [DEBUG]  @managerlib.py:496 -    1 already subscribed
2012-08-30 10:40:13,218 [DEBUG]  @managerlib.py:507 - Filtering 39 total pools
2012-08-30 10:40:13,218 [DEBUG]  @managerlib.py:512 - 	Removed 14 incompatible pools
2012-08-30 10:40:13,220 [DEBUG]  @managerlib.py:528 - 	Removed 11 pools overlapping existing entitlements
2012-08-30 10:40:13,220 [DEBUG]  @managerlib.py:542 - 	Removed 0 pools that we're already subscribed to
2012-08-30 10:40:13,220 [DEBUG]  @managerlib.py:545 - 	14 pools to display, 25 filtered out


[root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
subscription-manager-1.0.15-1.git.1.fecd579.el5
subscription-manager-migration-1.0.15-1.git.1.fecd579.el5
subscription-manager-firstboot-1.0.15-1.git.1.fecd579.el5
subscription-manager-gui-1.0.15-1.git.1.fecd579.el5
subscription-manager-migration-data-1.11.2.4-1.git.0.27879c1.el5

python-rhsm: 1.0.7-1.git.0.62a7320.el5
Comment 4 spandey 2012-08-30 05:36:58 EDT
using following setup , i got same issue.

[root@dhcp193-75 ~]# rpm -qa | grep subscription
subscription-manager-1.0.14-1.git.24.812ba3e.el5
subscription-manager-firstboot-1.0.14-1.git.24.812ba3e.el5
subscription-manager-migration-data-1.11.2.3-1.git.4.8bd27be.el5
subscription-manager-migration-1.0.14-1.git.24.812ba3e.el5
subscription-manager-gui-1.0.14-1.git.24.812ba3e.el5
[root@dhcp193-75 ~]# rpm -qa | grep python-rhsm
python-rhsm-1.0.5-1.git.1.1ce0910.el5
[root@dhcp193-75 ~]# subscription-manager-gui 
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 127, in _on_unsubscribe_prompt_response
    if self.backend.is_registered():
  File "/usr/share/rhsm/subscription_manager/gui/managergui.py", line 151, in is_registered
    return self.consumer.is_valid()
AttributeError: 'Backend' object has no attribute 'consumer'
Comment 5 Devan Goodwin 2012-08-31 09:22:28 EDT
Can reproduce, I think we may be confusing unsubscribe with unregister. But unsubuscribing in GUI we can definitely reproduce, has probably been there since 1.0.14.
Comment 6 Alex Wood 2012-08-31 10:12:55 EDT
commit 60c7bb107ff6290ccf2e5e4727db1d81745c79a2
Author:     Devan Goodwin <dgoodwin@redhat.com>
AuthorDate: Fri Aug 31 10:17:44 2012 -0300
Commit:     Devan Goodwin <dgoodwin@redhat.com>
CommitDate: Fri Aug 31 10:17:44 2012 -0300

Available in subscription-manager-1.0.17-1+
Comment 7 Devan Goodwin 2012-08-31 10:25:52 EDT
Fixed in subscription-manager git since cc6658b3d562f5c88a1dd62aae7b55b897151c64 and will be in 1.0.17.
Comment 9 spandey 2012-09-03 04:54:03 EDT
Verified using following rpm with rhel 5.9 

python-rhsm-1.0.7-1.el5
subscription-manager-migration-1.0.17-1.el5
subscription-manager-1.0.17-1.el5
subscription-manager-gui-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5
subscription-manager-migration-data-1.11.2.4-1.el5


Working fine resolving defect as verified.
Comment 10 Li Bin Liu 2012-09-06 22:58:40 EDT
*** Bug 854916 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2013-01-07 22:59:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.