Bug 851164 - Patch for BREE is still required.
Patch for BREE is still required.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tycho (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Roland Grunberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 07:54 EDT by Krzysztof Daniel
Modified: 2014-01-12 19:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 19:32:25 EDT
Type: Bug
Regression: RTP
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Daniel 2012-08-23 07:54:00 EDT
Lines 1-11 of http://pkgs.fedoraproject.org/cgit/eclipse.git/tree/eclipse-set-1.6-bree.patch?id=01bdabeb6879f69927f15b65a231c926db479bd0 are still required to properly build Eclipse.

Without that patch, the build fails during packaging phase that one of the dependencies has unsatisfied imports that should be in 1.6 BREE. To reproduce, checkout the latest eclipse and remove %patch2 line. Or comment it (#%%patch2).

org.apache.maven.InternalErrorException: Internal error: java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from org.apache.geronimo.specs.geronimo-annotation_1.1_spec 1.0.0 to package javax.lang.model 0.0.0.", "Unable to satisfy dependency from org.apache.geronimo.specs.geronimo-annotation_1.1_spec 1.0.0 to package javax.lang.model.element 0.0.0.", "Unable to satisfy dependency from org.apache.geronimo.specs.geronimo-annotation_1.1_spec 1.0.0 to package javax.lang.model.util 0.0.0.", "Unable to satisfy dependency from org.apache.geronimo.specs.geronimo-annotation_1.1_spec 1.0.0 to package javax.tools 0.0.0.", "Unable to satisfy dependency from org.apache.log4j 1.2.17 to package javax.management 0.0.0.", "Unable to satisfy dependency from org.glassfish.web.javax.servlet.jsp 2.2.5 to package javax.tools 0.0.0.", "No solution found because the problem is unsatisfiable."]
Comment 1 Roland Grunberg 2012-08-23 10:53:46 EDT
I think the problem is that when the execution environment is defined in the pom's target-platform configuration, it overrides the values from anywhere else. It should be possible to just override the target-platform setting in the same way that Tycho does for the Target Environment.
Comment 2 Roland Grunberg 2012-08-23 16:45:27 EDT
I've tested out the following Tycho (http://rgrunber.fedorapeople.org/tycho-0.16.0-5.1.df2c35.fc19.noarch.rpm) and it seems to build eclipse cbi on rawhide without the need for Patch2. If you can confirm this is the case, I'll go ahead and commit to rawhide, f18, and f17 as well.

The change ensures that projects of type 'eclipse-repository', 'eclipse-application', 'eclipse-update-site' get bumped to JavaSE-1.6 as well.
Comment 3 Fedora Update System 2012-08-24 15:03:30 EDT
tycho-0.16.0-6.df2c35.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tycho-0.16.0-6.df2c35.fc18
Comment 4 Fedora Update System 2012-08-24 17:33:37 EDT
Package tycho-0.16.0-6.df2c35.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tycho-0.16.0-6.df2c35.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12647/tycho-0.16.0-6.df2c35.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-08-28 14:16:04 EDT
Package tycho-0.16.0-7.df2c35.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tycho-0.16.0-7.df2c35.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12647/tycho-0.16.0-7.df2c35.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-09-17 19:32:25 EDT
tycho-0.16.0-7.df2c35.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.