Bug 851167 - [abrt] coreutils-8.12-7.fc16: __read_nocancel: Process /usr/bin/md5sum was killed by signal 6 (SIGABRT)
[abrt] coreutils-8.12-7.fc16: __read_nocancel: Process /usr/bin/md5sum was ki...
Status: CLOSED DUPLICATE of bug 851161
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
abrt_hash:8c91fa8ee4a7fdf0ea7d04a8b87...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 07:57 EDT by Denys Vlasenko
Modified: 2012-08-23 07:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 07:58:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (781 bytes, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details
File: environ (2.95 KB, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details
File: limits (1.29 KB, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details
File: cgroup (127 bytes, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details
File: maps (1.03 KB, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details
File: dso_list (320 bytes, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details
File: build_ids (123 bytes, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details
File: var_log_messages (1.10 KB, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details
File: open_fds (94 bytes, text/plain)
2012-08-23 07:57 EDT, Denys Vlasenko
no flags Details

  None (edit)
Description Denys Vlasenko 2012-08-23 07:57:36 EDT
Description of problem:
ABRT test, please disregard (testing repeated BZ submission)

Version-Release number of selected component:
coreutils-8.12-7.fc16

Additional info:
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        md5sum
crash_function: __read_nocancel
kernel:         3.4.2-1.fc16.i686.PAE

backtrace:
:[New LWP 4411]
:Core was generated by `md5sum'.
:Program terminated with signal 6, Aborted.
:#0  0xb77b3424 in __kernel_vsyscall ()
:
:Thread 1 (LWP 4411):
:#0  0xb77b3424 in __kernel_vsyscall ()
:No symbol table info available.
:#1  0xb76d24b3 in __read_nocancel () at ../sysdeps/unix/syscall-template.S:82
:No locals.
:#2  0xb76624b4 in _IO_file_xsgetn (fp=0xb7799a60, data=0x9c94860, n=32768) at fileops.c:1478
:        want = 32768
:        have = <optimized out>
:        count = <optimized out>
:        s = 0x9c94860 ""
:#3  0xb7663428 in _IO_sgetn (fp=0xb7799a60, data=0x9c94860, n=32768) at genops.c:500
:No locals.
:#4  0xb765f900 in __GI_fread_unlocked (buf=0x9c94860, size=1, count=32768, fp=0xb7799a60) at iofread_u.c:45
:        bytes_requested = 32768
:        bytes_read = <optimized out>
:#5  0x0804bd7b in fread_unlocked (__stream=0xb7799a60, __n=32768, __size=1, __ptr=0x9c94860) at /usr/include/bits/stdio2.h:372
:No locals.
:#6  md5_stream (stream=0xb7799a60, resblock=0xbfde13e4) at md5.c:162
:        n = <optimized out>
:        ctx = {A = 2584335342, B = 2928007722, C = 3239465270, D = 2498644481, total = {521437184, 0}, buflen = 0, buffer = {1, 3076505240, 0, 3078300624, 32, 134549492, 3078199904, 2, 0, 0, 3077407576, 134538534, 3078199904, 134549492, 3219002408, 134522260, 0, 0, 0, 0, 0, 2, 3219002328, 3076902400, 3078199904, 134522198, 134549492, 134522352, 0, 0, 0, 0}}
:        sum = 0
:        buffer = 0x9c94860 ""
:#7  0x0804a093 in digest_file (filename=0x804e526 "-", binary=<optimized out>, bin_result=0xbfde13e4 "\364\017\005\b\001") at md5sum.c:416
:        fp = 0xb7799a60
:        err = <optimized out>
:        is_stdin = <optimized out>
:#8  0x08049659 in main (argc=2, argv=0xbfde14c4) at md5sum.c:716
:        file_is_binary = 0
:        file = 0x804e526 "-"
:        bin_buffer_unaligned = "\364\017\005\b\001\000\000\000\r\214\004\b\270qy\267\002\000\000"
:        bin_buffer = 0xbfde13e4 "\364\017\005\b\001"
:        do_check = false
:        opt = <optimized out>
:        ok = true
:        binary = 0
:From        To          Syms Read   Shared Object Library
:0xb7605e90  0xb773e294  Yes         /lib/libc.so.6
:0xb77b4850  0xb77cdedf  Yes         /lib/ld-linux.so.2
:$1 = 0x0
:No symbol "__glib_assert_msg" in current context.
:eax            0x1000	4096
:ecx            0x9c94860	164186208
:edx            0x8000	32768
:ebx            0x0	0
:esp            0xbfde1188	0xbfde1188
:ebp            0x9c94860	0x9c94860
:esi            0xb7799a60	-1216767392
:edi            0x8000	32768
:eip            0xb77b3424	0xb77b3424 <__kernel_vsyscall+16>
:eflags         0x200246	[ PF ZF IF ID ]
:cs             0x73	115
:ss             0x7b	123
:ds             0x7b	123
:es             0x7b	123
:fs             0x0	0
:gs             0x33	51
:Dump of assembler code for function __kernel_vsyscall:
:   0xb77b3414 <+0>:	push   %ecx
:   0xb77b3415 <+1>:	push   %edx
:   0xb77b3416 <+2>:	push   %ebp
:   0xb77b3417 <+3>:	mov    %esp,%ebp
:   0xb77b3419 <+5>:	sysenter 
:   0xb77b341b <+7>:	nop
:   0xb77b341c <+8>:	nop
:   0xb77b341d <+9>:	nop
:   0xb77b341e <+10>:	nop
:   0xb77b341f <+11>:	nop
:   0xb77b3420 <+12>:	nop
:   0xb77b3421 <+13>:	nop
:   0xb77b3422 <+14>:	int    $0x80
:=> 0xb77b3424 <+16>:	pop    %ebp
:   0xb77b3425 <+17>:	pop    %edx
:   0xb77b3426 <+18>:	pop    %ecx
:   0xb77b3427 <+19>:	ret    
:End of assembler dump.
Comment 1 Denys Vlasenko 2012-08-23 07:57:39 EDT
Created attachment 606533 [details]
File: core_backtrace
Comment 2 Denys Vlasenko 2012-08-23 07:57:42 EDT
Created attachment 606534 [details]
File: environ
Comment 3 Denys Vlasenko 2012-08-23 07:57:44 EDT
Created attachment 606535 [details]
File: limits
Comment 4 Denys Vlasenko 2012-08-23 07:57:46 EDT
Created attachment 606536 [details]
File: cgroup
Comment 5 Denys Vlasenko 2012-08-23 07:57:48 EDT
Created attachment 606537 [details]
File: maps
Comment 6 Denys Vlasenko 2012-08-23 07:57:50 EDT
Created attachment 606538 [details]
File: dso_list
Comment 7 Denys Vlasenko 2012-08-23 07:57:52 EDT
Created attachment 606539 [details]
File: build_ids
Comment 8 Denys Vlasenko 2012-08-23 07:57:54 EDT
Created attachment 606540 [details]
File: var_log_messages
Comment 9 Denys Vlasenko 2012-08-23 07:57:56 EDT
Created attachment 606541 [details]
File: open_fds
Comment 10 Denys Vlasenko 2012-08-23 07:58:37 EDT
Please don't close this BZ yet, I need it to be open for abrt tests
Comment 11 Denys Vlasenko 2012-08-23 07:58:58 EDT

*** This bug has been marked as a duplicate of bug 851161 ***

Note You need to log in before you can comment on or make changes to this bug.