Bug 851170 - include default_locale info in `user list` output
include default_locale info in `user list` output
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 08:01 EDT by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 11:15:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2012-08-23 08:01:33 EDT
Description of problem:
recent Katello CLI call `user list` does not output the users' default locale info.

Version-Release number of selected component (if applicable):
pulp-common-1.1.12-1.el6.noarch
katello-common-1.0.6-1.el6.noarch
qpid-cpp-server-0.14-14.el6_2.x86_64
katello-selinux-1.1.0-1.git.18.d10e8a3.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.1.2-1.git.162.09c0162.el6.noarch
katello-repos-1.1.2-1.el6.noarch
katello-glue-foreman-1.0.6-1.el6.noarch
qpid-cpp-client-0.14-14.el6_2.x86_64
pulp-1.1.12-1.el6.noarch
mod_wsgi-3.3-3.pulp.el6.x86_64
katello-glue-candlepin-1.0.6-1.el6.noarch
qpid-cpp-server-ssl-0.14-14.el6_2.x86_64
candlepin-tomcat6-0.7.6.2-1.el6.noarch
pulp-selinux-server-1.1.12-1.el6.noarch
katello-configure-1.0.2-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.1.0-1.git.22.d10e8a3.el6.noarch
python-oauth2-1.5.170-2.pulp.el6.noarch
python-qpid-0.14-7.el6_2.noarch
candlepin-0.7.6.2-1.el6.noarch
katello-glue-pulp-1.0.6-1.el6.noarch
qpid-cpp-client-ssl-0.14-14.el6_2.x86_64
katello-1.0.6-1.el6.noarch
katello-certs-tools-1.1.8-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-1.1.2-1.git.162.09c0162.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. `user list`
2.
3.
  
Actual results:
no info about the locale

Expected results:
Users' default locale preference should be listed.

Additional info:
Comment 1 Og Maciel 2012-08-23 11:03:38 EDT
As per pull request https://github.com/Katello/katello/pull/436/ you can already get the default locale for individual users:

katello> user info --username user1
--------------------------------------------------------------------------------
                               User Information
--------------------------------------------------------------------------------
Id:                   3
Username:             user1
Email:                bbuckingham@redhat.com
Disabled:             False
Default Organization: ACME_Corporation
Default Environment:  dev
Default Locale:       ru
Comment 2 Mike McCune 2012-09-05 11:15:08 EDT
since this is already in the info call it is too much information to stuff in the list output

Note You need to log in before you can comment on or make changes to this bug.