Bug 851171 - RFE: add registry option to disable off screen surfaces
RFE: add registry option to disable off screen surfaces
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-qxl-driver-win (Show other bugs)
unspecified
All Windows
high Severity high
: ---
: 3.1.0
Assigned To: Alon Levy
Desktop QE
: FutureFeature
Depends On:
Blocks: 844962 856305
  Show dependency treegraph
 
Reported: 2012-08-23 08:03 EDT by Alon Levy
Modified: 2014-06-10 22:19 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous releases performance issues were sometimes encountered when using the QXL driver to draw off screen surfaces. As a workaround for this issue a new "DisableSurfaces" registry key is now supported. If the new key is set to any value, including 0, then drawing of off screen surfaces is disabled. To set this key: 1) Launch the regedit.exe executable. 2) Find the "HARDWARE\\DEVICEMAP\\VIDEO\\Device\\Video0" entry. This key contains the UUID of the video device currently in use. 3) Find the "Computer\KKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video\{uuid}\0000\" entry - replacing {uuid} with the UUID located in the previous step - and create the "DisabledSurfaces" key.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 13:16:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alon Levy 2012-08-23 08:03:36 EDT
Offscreen surfaces create some regressions in performance. Customer verified that disabling them is a workaround for bug 844962.
Comment 1 Andrew Cathrow 2012-08-24 07:55:12 EDT
Alon, what's your thoughts on the default behaviour - off on on?
Comment 2 Alon Levy 2012-08-24 08:36:09 EDT
Good point. Off would be better perhaps - Yonit looked at the surface usage patterns, adding a needinfo.
Comment 18 errata-xmlrpc 2012-12-04 13:16:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1503.html

Note You need to log in before you can comment on or make changes to this bug.