Bug 851198 - ovirt-engine-backend [TEXT]: please remove the word "Action" from attach/detach CanDoAction
ovirt-engine-backend [TEXT]: please remove the word "Action" from attach/deta...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
x86_64 Linux
medium Severity low
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
Dafna Ron
storage
:
: 833900 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 09:32 EDT by Dafna Ron
Modified: 2016-02-10 15:24 EST (History)
12 users (show)

See Also:
Fixed In Version: SI21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (144.52 KB, application/x-xz)
2012-08-23 09:32 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-23 09:32:44 EDT
Created attachment 606563 [details]
log

Description of problem:

detach: 

Cannot Dettach Action from Virtual Machine Disk. The VM status is illegal.

attach:

Cannot attach Action to Virtual Machine Disk. Disk is Illegal. Illegal disks can only be deleted.

Version-Release number of selected component (if applicable):

si15

How reproducible:

100%

Steps to Reproduce:
1. attach: try to attach a disk which is in illegal state or two bootable disks to the same vm
2. detach: try to detach a disk while running the vm at the same time.
3.
  
Actual results:

both attach and detach have the word "Action" in the CanDoAction

Expected results:

we should remove the work "Action" from CanDoAction

Additional info:
Comment 1 Ayal Baron 2012-08-23 17:34:52 EDT
(In reply to comment #0)
> Created attachment 606563 [details]
> log
> 
> Description of problem:
> 
> detach: 
> 
> Cannot Dettach Action from Virtual Machine Disk. The VM status is illegal.

Need to fix:
    @DefaultStringValue("$action attach Action to")
    String VAR__ACTION__ATTACH_ACTION_TO();

    @DefaultStringValue("$action Dettach Action from")
    String VAR__ACTION__DETACH_ACTION_TO();

Also note that "Dettach" should be written: "detach"
Comment 2 Einav Cohen 2012-08-25 03:59:09 EDT
Note that the .properties file(s) should probably be changed, rather than the default values in the java file(s) with the Constants interface (we would like to get rid of the defaults within the code eventually).
Comment 3 Asaf Shakarchi 2012-09-09 11:11:43 EDT
this is actually wrong in user portal as well,
Patch submitted: http://gerrit.ovirt.org/#/c/7880/
Fixed in all relevant locations.
Comment 4 Allon Mureinik 2012-10-15 04:45:56 EDT
merged Iae923c89c71eccfc695cbb8e5dd417808c04d54b
Comment 5 Dafna Ron 2012-10-21 09:45:49 EDT
verified on si21.1 
tested on two bootable disks since illegal are filtered by UI
Comment 6 Vered Volansky 2012-11-06 03:40:58 EST
*** Bug 833900 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.