This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 851229 - pushcount help in repo uploads mentions it defaults to 1 but if you don't provide a value errata create fails.
pushcount help in repo uploads mentions it defaults to 1 but if you don't pro...
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 39
Assigned To: Jay Dobies
Preethi Thomas
: Triaged
Depends On:
Blocks: 848520 852799
  Show dependency treegraph
 
Reported: 2012-08-23 10:25 EDT by Preethi Thomas
Modified: 2013-09-09 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 852799 (view as bug list)
Environment:
Last Closed: 2013-01-09 12:08:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-08-23 10:25:26 EDT
Description of problem:
help text for pushcount in errata 
 --pushcount         - pushcount for this erratum; an integer, defaults to 1 

but if you try to create an errata without providing pushcount, the errata create fails.
[root@pulp-candidate scripts]# ./errata1.sh 
+----------------------------------------------------------------------+
                            Erratum Creation
+----------------------------------------------------------------------+

Error: Invalid pushcount []; should be an integer 

Version-Release number of selected component (if applicable):

[root@pulp-candidate scripts]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.1-1.fc17.noarch
[root@pulp-candidate scripts]# 

How reproducible:


Steps to Reproduce:
1.create a repo
2. run repo uploads errata with all the required fields and do not provide a --pushcount
3.
  
Actual results:

[root@pulp-candidate scripts]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.1-1.fc17.noarch
[root@pulp-candidate scripts]# 

Expected results:


Additional info:
Comment 1 Jay Dobies 2012-09-04 14:08:09 EDT
Already talked to you, but I can't reproduce this. Below is the command I used, going down the list of required attributes. Push count was not specified.


$ pulp-admin repo uploads errata --repo-id bugs --erratum-id err --title Err --description ErrD --version 1.0.0 --release 1 --type bugzilla --status final --updated "2012-01-01 12:00:00" --from jdob@redhat.com --pkglist-csv /home/jdob/code/pulp/playpen/v2_demos/errata_upload/package_list.csv --issued "2012-01-01 01:00:00"
+----------------------------------------------------------------------+
                            Erratum Creation
+----------------------------------------------------------------------+

Starting upload of selected packages. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Importing into the repository...
... completed

Deleting the upload request...
... completed
Comment 2 Preethi Thomas 2012-09-04 20:55:37 EDT
verified
[root@preethi-el6-pulp ~]# rpm -q pulp-rpm-server
pulp-rpm-server-2.0.2-1.el6.noarch

[root@preethi-el6-pulp ~]# pulp-admin repo uploads errata --repo-id bugs --erratum-id err --title Err --description ErrD --version 1.0.0 --release 1 --type bugzilla --status final --updated "2012-01-01 12:00:00" --from jdob@redhat.com --pkglist-csv /root/scripts/package_list.csv --issued "2012-01-01 01:00:00"+----------------------------------------------------------------------+
                            Erratum Creation
+----------------------------------------------------------------------+

Starting upload of selected packages. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Importing into the repository...
... completed

Deleting the upload request...
... completed


[root@preethi-el6-pulp scripts]# ./errata1.sh 
+----------------------------------------------------------------------+
                            Erratum Creation
+----------------------------------------------------------------------+

Erratum Details:
  Id:                DEMO_2_ID_1346806747
  Title:             Demo Errata created on Tue Sep  4 20:59:07 EDT 2012
  Type:              enhancement
  Severity:          
  Status:            final
  Solution:          
  Issued:            Tue Sep  4 20:59:07 EDT 2012
  Updated:           Tue Sep  4 20:59:07 EDT 2012
  From Str:          pulp-list@redhat.com
  Version:           1
  Release:           el6
  Description:       This is the description for DEMO_2_ID_1346806747
  Summary:           
  Pkglist:           
    Name:     el6
    Packages: 
      Arch:     i386
      Epoch:    0
      Filename: xen-3.0.3-105.el5_5.2.i386.rpm
      Name:     xen
      Release:  105.el5_5.2
      Src:      xen-3.0.3-105.el5_5.2.src.rpm
      Sums:     0f1174b38383b01a77278b0d9f289987
      Type:     md5
      Version:  3.0.3
      Arch:     i386
      Epoch:    0
      Filename: xen-devel-3.0.3-105.el5_5.2.i386.rpm
      Name:     xen-devel
      Release:  105.el5_5.2
      Src:      xen-3.0.3-105.el5_5.2.src.rpm
      Sums:     3680d1dde276fd155ead7203508fed30
      Type:     md5
      Version:  3.0.3
    Short:    
  Pushcount:         1
  Reboot Suggested:  False
  References:        
    Href:  http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=580398
    Id:    580398
    Title: Windows Logo testing likes its PCI classes to be consistent
    Type:  bugzilla
    Href:  http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=517903
    Id:    517903
    Title: Add -no-kvm-pit-reinject in qemu cmdline for RHEL guests
    Type:  bugzilla
  Rights:            

Starting upload of selected packages. If this process is stopped through ctrl+c,
the uploads will be paused and may be resumed later using the resume command or
cancelled entirely using the cancel command.

Importing into the repository...
... completed

Deleting the upload request...
... completed

[root@preethi-el6-pulp scripts]#
Comment 3 Preethi Thomas 2013-01-09 12:08:03 EST
Pulp v2.0 released

Note You need to log in before you can comment on or make changes to this bug.