Bug 851231 - RFE - When host status is changing to Up, network configuration should be verified to be compatible with other hosts in cluster
RFE - When host status is changing to Up, network configuration should be ver...
Status: CLOSED DUPLICATE of bug 856337
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: lpeer
network
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 10:29 EDT by David Jaša
Modified: 2016-02-10 14:55 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 06:26:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-08-23 10:29:14 EDT
Description of problem:
When host status is changing to Up, network configuration should be verified to be compatible with other hosts in cluster

Version-Release number of selected component (if applicable):
all the way up to si14

How reproducible:
always

Steps to Reproduce:
1. create a DC, Cluster with allowed migration
2. and add a host1 to with its NIC in lan1
3. add host2 to a DC, host2 NIC is only in lan2 (with at least one hop to the gateway of lan1)
  
Actual results:
host2 is installed, rebooted and put to "Up" state successfully

Expected results:
host2 should be put to "Down" state with error that lan1 network segment is not reachable from the host (because live migration between host1 and host2 would break networking). 

Additional info:
This principle is not limited to the lan segment VM NICs are plugged to, it applies to management, storage, display and migration network functions, too, just a bit differently (migration and management networks need just inter-host reachability etc.).
Comment 1 Simon Grinberg 2012-08-27 07:42:44 EDT
What you are asking for is to verify connectivity between hosts. This is an RFE, 

ATM what is verified is that: 
Connectivity exists to the host.
The host has all the required networks, we don't even verify same subnets since connectivity may still exist via routing. 
If migration have extra requirements then those should be considered as well.

Not for RHEV3.1, should consider for 3.2
Comment 2 lpeer 2012-09-12 06:26:49 EDT
This RFE is very much related to another RFE - BUG 856337

BUG 856337 is more focused on discovery but the motivation is very similar, both RFEs want to reduce the occurrences of network misconfiguration.

I think we'll prioritize this request as part of handling the second RFE, I am closing this as a duplicate of the other one and adding there a comment there to consider this request as well.

*** This bug has been marked as a duplicate of bug 856337 ***

Note You need to log in before you can comment on or make changes to this bug.