Bug 851248 - RHEVM - Backend: Can't add Gluster hosts
RHEVM - Backend: Can't add Gluster hosts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Selvasundaram
Daniel Paikov
gluster
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 11:05 EDT by Daniel Paikov
Modified: 2016-02-10 13:59 EST (History)
12 users (show)

See Also:
Fixed In Version: si21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-08-23 11:05:51 EDT
* Try to add a Gluster host to a Gluster cluster.
* Bootstrap is run on the host.
* Gluster host installation fails because there no repos are found with vdsm*.rpm (even though Gluster hosts have vdsm installed out of the box).
* If vdsm issue is fixed, host installation fails for finding mesa-libGLU.rpm (which isn't needed on a Gluster host).
* Gluster host installation shouldn't use bootstrap or use a very modified bootstrap, since Gluster hosts are closer to RHEVH hosts and have all necessary packages installed out of the box.
Comment 1 Shireesh 2012-09-12 08:22:52 EDT
Following engine patches upstream would help proper bootstrapping of gluster hosts:

http://gerrit.ovirt.org/7243
http://gerrit.ovirt.org/7244
Comment 2 Selvasundaram 2012-10-03 02:51:36 EDT
Following patches in downstream would help proper bootstrapping of gluster hosts,

https://gerrit.eng.lab.tlv.redhat.com/#/c/2153/
https://gerrit.eng.lab.tlv.redhat.com/#/c/2154/
https://gerrit.eng.lab.tlv.redhat.com/#/c/2155/

And the dependent patch,
https://gerrit.eng.lab.tlv.redhat.com/#/c/2152/
Comment 3 Daniel Paikov 2012-11-27 10:49:17 EST
Still fails on si24.4. Bootstrap still requires a vdsm RPM, tries to look for it on yum, and fails:

Sun, 02 Dec 2012 23:15:07 DEBUG    vds_bootstrap 997 **** Start VDS Validation ****
Sun, 02 Dec 2012 23:15:07 DEBUG    vds_bootstrap 867 Entered VdsValidation(subject = '10.35.97.162', random_num = 'eeaac474-8bb9-4784-bc17-6aa0d0b15966', rev_num = 'None', installVirtualizationService = 'False', installGlusterService = 'True', bridgeName = 'rhevm')
Sun, 02 Dec 2012 23:15:07 DEBUG    deployUtil 707 setHostTime start.
Sun, 02 Dec 2012 23:15:07 DEBUG    deployUtil 136 ['/usr/sbin/hwclock', '--set', '--utc', '--date=2012-12-02 23:15:08 UTC']
Sun, 02 Dec 2012 23:15:08 DEBUG    deployUtil 144 
Sun, 02 Dec 2012 23:15:08 DEBUG    deployUtil 145 
Sun, 02 Dec 2012 23:15:08 DEBUG    deployUtil 136 ['/usr/sbin/hwclock', '-s']
Sun, 02 Dec 2012 23:15:10 DEBUG    deployUtil 144 
Sun, 02 Dec 2012 23:15:10 DEBUG    deployUtil 145 
Sun, 02 Dec 2012 23:15:10 DEBUG    deployUtil 730 setHostTime end. Return:True
Sun, 02 Dec 2012 23:15:10 DEBUG    vds_bootstrap 213 <BSTRAP component='SET_SYSTEM_TIME' status='OK' message='setSystemTime ended successfully'/>
Sun, 02 Dec 2012 23:15:10 DEBUG    __init__ 658 Setting up Package Sacks
Sun, 02 Dec 2012 23:15:11 DEBUG    deployUtil 1135 yumSearch: package vdsm not found!
Sun, 02 Dec 2012 23:15:11 ERROR    vds_bootstrap 234 Unable to fetch vdsm package. Please check if host is registered to RHN, Satellite or other yum repository
Sun, 02 Dec 2012 23:15:11 DEBUG    vds_bootstrap 213 <BSTRAP component='RHN_REGISTRATION' status='FAIL' message='Unable to fetch vdsm package. Please check if host is registered to RHN, Satellite or other yum repository'/>
Sun, 02 Dec 2012 23:15:11 ERROR    vds_bootstrap 882 checkRegistration test failed
Sun, 02 Dec 2012 23:15:11 DEBUG    vds_bootstrap 1019 <BSTRAP component='RHEV_INSTALL' status='FAIL'/>
Sun, 02 Dec 2012 23:15:11 DEBUG    vds_bootstrap 1021 **** End VDS Validation ****
Comment 4 Shireesh 2012-11-28 01:01:51 EST
What kind of a 'gluster host' are you using? You should be using a an RHS node created using the RHS ISO.
Comment 5 Daniel Paikov 2012-11-28 09:09:17 EST
(In reply to comment #4)
> What kind of a 'gluster host' are you using? You should be using a an RHS
> node created using the RHS ISO.

Yes, I'm using a host installed from: RHS-2.0-20120621.2-RHS-x86_64-DVD1.iso
Comment 6 Shireesh 2012-11-28 09:23:11 EST
If you use this older 2.0 ISO, you'll have to register to RHS channel.
If you use latest 2.0plus ISO (RHS-2.0-20121110.0), it should just work.
Comment 7 Daniel Paikov 2012-11-28 09:30:08 EST
(In reply to comment #6)
> If you use this older 2.0 ISO, you'll have to register to RHS channel.
> If you use latest 2.0plus ISO (RHS-2.0-20121110.0), it should just work.

Great, please send me a URL where I can download RHS-2.0-20121110.0 and I'll re-test it.
Comment 8 Selvasundaram 2012-11-28 09:55:59 EST
(In reply to comment #7)
> (In reply to comment #6)
> > If you use this older 2.0 ISO, you'll have to register to RHS channel.
> > If you use latest 2.0plus ISO (RHS-2.0-20121110.0), it should just work.
> 
> Great, please send me a URL where I can download RHS-2.0-20121110.0 and I'll
> re-test it.

http://download.devel.redhat.com/composes/candidates/RHS-2.0-20121110.0/2.0/RHS/x86_64/iso/
Comment 9 Shireesh 2012-11-28 10:02:22 EST
For reference: Bug 874501 has above ISO tested with RHEV-M, and is in VERIFIED state.
Comment 10 Daniel Paikov 2012-11-28 11:24:33 EST
Tested successfully with RHS-2.0-20121110.0. Closing as Verified.

Note You need to log in before you can comment on or make changes to this bug.