Bug 851332 - REST: /api/providers/{id} returns unusable organization_id
REST: /api/providers/{id} returns unusable organization_id
Status: CLOSED DUPLICATE of bug 851331
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Bryan Kearney
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 16:09 EDT by Brad P. Crochet
Modified: 2013-08-16 13:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 16:19:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad P. Crochet 2012-08-23 16:09:58 EDT
Description of problem:
/api/providers/{id} returns:

{"created_at":"2012-08-23T19:53:38Z","organization_id":1,"updated_at":"2012-08-23T19:53:38Z","sync_state":"not_synced","last_sync":null,"task_status_id":null,"description":"My Provider Description","name":"My Provider5","provider_type":"Custom","repository_url":null,"id":160}

I cannot then take "organization_id" and pass it to:

/api/organizations/{organization_id}

/api/organizations requites the Candlepin key for the owner, not the numerical key.

The return should allow me to use the org id directly. Currently, one would need to get back a list of all organizations, then iterate over this list to find the right one.

Version-Release number of selected component (if applicable):
katello-1.0.4-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. curl -k https://localhost/katello/api/providers/1
2. Get back json, use organization_id directly in 
3. curl -k https://localhost/katello/api/organizations/{organization_id}
  
Actual results:
organization_id contains directly unusable id

Expected results:
organization_id contains directly usable id
Comment 1 Brad P. Crochet 2012-08-23 16:19:49 EDT

*** This bug has been marked as a duplicate of bug 851331 ***
Comment 2 Mike McCune 2013-08-16 13:54:59 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.