Bug 851341 - Bad translation on some gnome-shell elements
Bad translation on some gnome-shell elements
Status: CLOSED NEXTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: Spanish [es] (Show other bugs)
unspecified
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Domingo Becker
Domingo Becker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 17:07 EDT by Benjamin Ariel Nava Martinez
Modified: 2012-08-23 23:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-23 17:52:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benjamin Ariel Nava Martinez 2012-08-23 17:07:33 EDT
Description of problem:
Some elements of the gnome-shell present bad translations using the es_MX locale.

Version-Release number of selected component (if applicable):
Fedora 17 with the latest updates (08-23-2012), Gnome 3.4.2

How reproducible:
The authentication modal dialog prompt displays, in the password field, and the removable drives notification display english text instead of the correct translations.

Steps to Reproduce:
1. Trigger an authentication prompt, and look beside the password field
2. Plug a device, eject it and look at the notification
3. All these using the locale es_MX translation.
  
Actual results:
English text

Expected results:
Spanish (es_MX) localized text

Additional info:
I can include screenshots if you want
Comment 1 Piotr Drąg 2012-08-23 17:52:26 EDT
These are expected on GNOME 3.4 and Fedora 17. "Password" string issues are recently resolved bugs in polkit [1] and gnome-shell [2]. Unfortunately, it doesn't look like they're going to be backported.

Eject notification comes from Fedora-specific patch [3], which can't be translated because of technical reasons. It has been upstreamed already, so it will be resolved in GNOME 3.6/Fedora 18.

[1] http://cgit.freedesktop.org/polkit/commit/?id=facadfb5c8c52ba45fd20ffe3b6d3ddd4208a427

[2] http://git.gnome.org/browse/gnome-shell/commit/?id=46cf9faa11bb64eb661a4f359256ae581bff2ea7

[3] http://pkgs.fedoraproject.org/cgit/gnome-shell.git/tree/autorun-add-a-notification-when-unmounting-drives.patch?h=f17
Comment 2 Benjamin Ariel Nava Martinez 2012-08-23 23:42:17 EDT
Well, that explains everything, I'll wait for Fedora 18 then. Thanks!

Note You need to log in before you can comment on or make changes to this bug.