Bug 851427 - quickstart : missing openshift module when deploying dancer example
quickstart : missing openshift module when deploying dancer example
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 03:50 EDT by Meng Bo
Modified: 2015-05-14 22:03 EDT (History)
3 users (show)

See Also:
Fixed In Version: devenv_2196
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-08-24 03:50:11 EDT
Description of problem:
When deploy dancer example from github, openshift module cannot be found during the git push. After build finished, the homepage of dancer can be accessed, but the app status always show as "Application 'dancer' is either stopped or inaccessible" via 'rhc app status'

Version-Release number of selected component (if applicable):
https://github.com/openshift/dancer-example

How reproducible:
always

Steps to Reproduce:
1.Create dancer app by following the github steps
2.
3.
  
Actual results:
Some failed appears about cannot find the openshift module and app status always show as "Application 'dancer' is either stopped or inaccessible".

Expected results:
No failed message appears, and app status show as normal.

Additional info:
Checked this on both PROD and STG. Got the same result.

===========
remote: ! Finding openshift on cpanmetadb failed.
remote: ! Finding openshift on search.cpan.org failed.
remote: ! Finding openshift on mirror http://mirror1.stg.rhcloud.com/mirror/perl/CPAN failed.
remote: ! Couldn't find module or a distribution openshift
remote: --> Working on Plack::Handler::Apache2
remote: Fetching http://mirror1.stg.rhcloud.com/mirror/perl/CPAN/authors/id/M/MI/MIYAGAWA/Plack-1.0002.tar.gz ... OK
remote: ==> Found dependencies: ExtUtils::MakeMaker
remote: --> Working on ExtUtils::MakeMaker
===========


==========
remote: ! Finding openshift on cpanmetadb failed.
remote: ! Finding openshift on search.cpan.org failed.
remote: ! Finding openshift on mirror http://mirror1.prod.rhcloud.com/mirror/perl/CPAN failed.
remote: ! Couldn't find module or a distribution openshift
==========


App actually started and can be accessed.
[root@localhost dancer]# rhc app status -a dancer
Password: ******


RESULT:
Application 'dancer' is either stopped or inaccessible
Comment 1 Troy Dawson 2012-08-24 10:38:10 EDT
In the past, this has failed because of mirror problems, so I can understand why this was assigned to me.  But this time I think it was missasigned.

That error shown about not being able to find openshift anywhere has nothing to do with the mirrors, it simply isn't in CPAN, and so it can't find it.

From what I see, nothing has changed about this app.  It still installs the way it always has, with the same errors.  If you go to the web site, it is running, and you can work with it.

But now, we are checking it with "rhc app status" and *that* is failling.
In the past, I never checked it with "rhc app status" so I don't know if it has always failed or not.

From what I see, my "git push" looks like it worked

=======================
...
remote: Running .openshift/action_hooks/build
remote: Running .openshift/action_hooks/deploy
remote: Starting application...
remote: Done
remote: Running .openshift/action_hooks/post_deploy
To ssh://xxxxxx@dancer-tdawson.rhcloud.com/~/git/dancer.git/
   fc6f5e1..0f8fcfe  master -> master
=======================

And if I go to the website, it looks like it's working
http://dancer-tdawson.rhcloud.com/

Before I did my git push, I did an "rhc app status" and it seemed like it was working.
===============
$ rhc app status -a dancer
Password: *********

RESULT:
Total Accesses: 4
Total kBytes: 5
CPULoad: .0380952
Uptime: 105
ReqPerSec: .0380952
BytesPerSec: 48.7619
BytesPerReq: 1280
BusyWorkers: 1
IdleWorkers: 0
Scoreboard: W....
=================

But after I did my git push, I get the following (and I've waited for a while, still getting it)

====================
$ rhc app status -a dancer
Password: *********

RESULT:
Application 'dancer' is either stopped or inaccessible
====================

I think this needs to be re-assigned to either the app status maintainer, or the dancer quickstart maintainer.
Comment 2 Ram Ranganathan 2012-09-18 18:44:08 EDT
This is actually an issue w/ the perl cartridge build script uses /usr/lib/rpm/perl.req  which causes openshift to show up as a dependency and openshift.pm is a bundled library within the dancer app. 

Will fix in the perl cartridge.
Comment 3 Ram Ranganathan 2012-09-18 21:27:14 EDT
Fixed and waiting on pull request: 
   https://github.com/openshift/crankcase/pull/504
Comment 4 Xiaoli Tian 2012-09-19 00:49:05 EDT
(In reply to comment #3)
> Fixed and waiting on pull request: 
>    https://github.com/openshift/crankcase/pull/504

Above pull request is merged in devenv_2196
Comment 5 Meng Bo 2012-09-24 01:48:14 EDT
Checked on latest devenv_2215, the perl dancer example pushed without error.
It will not try to find moudle named 'openshift'.

And after git push, the app status shows correctly. App can be accessed via web browser.

[root@F17x64-openshift dancer]# rhc app status -a dancer

RESULT:
Total Accesses: 0
Total kBytes: 0
Uptime: 576
ReqPerSec: 0
BytesPerSec: 0
BusyWorkers: 1
IdleWorkers: 0
Scoreboard: W....

Mark bug as verfied.

Note You need to log in before you can comment on or make changes to this bug.