Bug 851527 - SKS initscripts do not work [NEEDINFO]
SKS initscripts do not work
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: sks (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Bebout
Fedora Extras Quality Assurance
:
: 890639 1087115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 09:42 EDT by Héctor Acosta
Modified: 2014-08-29 15:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: sks-1.1.5-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-26 21:31:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sparks: needinfo? (nb)


Attachments (Terms of Use)
Patched sks-db initscript (2.12 KB, patch)
2012-08-24 09:44 EDT, Héctor Acosta
no flags Details | Diff
Patched sks-recon init script (2.08 KB, patch)
2012-08-24 09:44 EDT, Héctor Acosta
no flags Details | Diff
Patched sks-db initscript (2.15 KB, application/octet-stream)
2012-08-24 13:03 EDT, Héctor Acosta
no flags Details
Patched sks-recon init script (2.10 KB, patch)
2012-08-24 13:04 EDT, Héctor Acosta
no flags Details | Diff
Patched sks-db initscript (2.15 KB, application/octet-stream)
2012-08-24 13:09 EDT, Héctor Acosta
no flags Details

  None (edit)
Description Héctor Acosta 2012-08-24 09:42:50 EDT
Description of problem:

The initscripts included in the sks package have a couple of problems:
* They have extra whitespace
* The base directory is hardcoded
* They won't start unless a non-empty configfile is created (which is not included with the rpm)

Version-Release number of selected component (if applicable):
1.1.3


Steps to Reproduce:
1. yum install sks
2. /etc/init.d/sks-db start

  
Actual results:
The script exits with exit status 6

Expected results:
The script starts the service

Additional info:
Comment 1 Héctor Acosta 2012-08-24 09:44:02 EDT
Created attachment 606861 [details]
Patched sks-db initscript
Comment 2 Héctor Acosta 2012-08-24 09:44:57 EDT
Created attachment 606862 [details]
Patched sks-recon init script
Comment 3 Héctor Acosta 2012-08-24 13:03:31 EDT
Created attachment 606916 [details]
Patched sks-db initscript
Comment 4 Héctor Acosta 2012-08-24 13:04:17 EDT
Created attachment 606917 [details]
Patched sks-recon init script
Comment 5 Héctor Acosta 2012-08-24 13:09:50 EDT
Created attachment 606918 [details]
Patched sks-db initscript

Sorry for the spam. I accidentally submited the wrong version and then obsoleted the wrong attachment.
Comment 6 Eric Christensen 2014-06-27 10:19:51 EDT
What's the status of this?
Comment 7 Nick Bebout 2014-08-11 22:14:45 EDT
*** Bug 1087115 has been marked as a duplicate of this bug. ***
Comment 8 Nick Bebout 2014-08-11 22:18:57 EDT
*** Bug 890639 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2014-08-11 22:20:29 EDT
sks-1.1.5-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sks-1.1.5-2.fc19
Comment 10 Fedora Update System 2014-08-11 22:22:51 EDT
sks-1.1.5-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sks-1.1.5-2.fc20
Comment 11 Fedora Update System 2014-08-11 23:11:11 EDT
sks-1.1.5-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/sks-1.1.5-2.el6
Comment 12 Fedora Update System 2014-08-12 20:39:05 EDT
Package sks-1.1.5-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing sks-1.1.5-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2185/sks-1.1.5-2.el6
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2014-08-26 21:31:18 EDT
sks-1.1.5-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2014-08-26 21:32:34 EDT
sks-1.1.5-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2014-08-29 15:43:11 EDT
sks-1.1.5-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.