Bug 851723 - Harddrive is not detected by Fedora using nvidia chip
Harddrive is not detected by Fedora using nvidia chip
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-24 16:20 EDT by Erik Schilling
Modified: 2012-08-25 11:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-25 11:11:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of fpaste --sysinfo (9.07 KB, text/plain)
2012-08-24 16:20 EDT, Erik Schilling
no flags Details
output of dmesg (54.60 KB, text/plain)
2012-08-24 16:21 EDT, Erik Schilling
no flags Details
output of fdisk -l (1.87 KB, text/plain)
2012-08-24 16:22 EDT, Erik Schilling
no flags Details
output of lspci (1.75 KB, text/plain)
2012-08-24 16:22 EDT, Erik Schilling
no flags Details
abrt also noticed the problem as i just noticed. This is the problem logged to file. (2.09 KB, text/plain)
2012-08-25 03:12 EDT, Erik Schilling
no flags Details
photo of the infos that the bios displays me when i press F1 (2.55 MB, image/jpeg)
2012-08-25 04:21 EDT, Erik Schilling
no flags Details
photo of the sata port 0 configuration in the bios (265.63 KB, image/jpeg)
2012-08-25 04:24 EDT, Erik Schilling
no flags Details
output of ls /dev (988 bytes, text/plain)
2012-08-25 06:06 EDT, Erik Schilling
no flags Details

  None (edit)
Description Erik Schilling 2012-08-24 16:20:42 EDT
Created attachment 606954 [details]
output of fpaste --sysinfo

Description of problem:
I am trying to install Fedora on this machine (see info in the attached files).
Fedora fails to recognise the harddrive of the machine --> only the usb stick i am booting with is found. On IRC people told me that it is probably a problem related to bad support for nvidia chips. Dmesg lists some errors/warnings (see attachments).

Best regards
Erik Schilling (Ablu)
Comment 1 Erik Schilling 2012-08-24 16:21:32 EDT
Created attachment 606955 [details]
output of dmesg
Comment 2 Erik Schilling 2012-08-24 16:22:16 EDT
Created attachment 606956 [details]
output of fdisk -l
Comment 3 Erik Schilling 2012-08-24 16:22:43 EDT
Created attachment 606957 [details]
output of lspci
Comment 4 Erik Schilling 2012-08-25 01:40:55 EDT
Sorry. I forgot to add the info that the drive is detected by Windows XP that already was installed.

Best regards
Comment 5 Erik Schilling 2012-08-25 03:12:18 EDT
Created attachment 606979 [details]
abrt also noticed the problem as i just noticed. This is the problem logged to file.

I just noticed that abrt noticed the problem too. I told it to log it into the file i just uploaded.
Comment 6 Erik Schilling 2012-08-25 04:21:04 EDT
Created attachment 606982 [details]
photo of the infos that the bios displays me when i press F1
Comment 7 Erik Schilling 2012-08-25 04:24:17 EDT
Created attachment 606983 [details]
photo of the sata port 0 configuration in the bios

I cannot change anything in the bios related to the sata port except setting a password.
Comment 8 Erik Schilling 2012-08-25 06:06:09 EDT
Created attachment 606985 [details]
output of ls /dev

I just thought about checking the other drives (only cd drive). It does not get detected as well...
Attached output of ls /dev.
Comment 9 Erik Schilling 2012-08-25 11:11:43 EDT
Switching SATA Controlled Mode to "Enhanced" in the bios fixed the issue for me.

Marking as not a bug though it would be nice if it could work without bios tinkering

Note You need to log in before you can comment on or make changes to this bug.