Bug 851829 - Return base domain for new applications in api document (as descriptor on links?)
Return base domain for new applications in api document (as descriptor on lin...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: FutureFeature
: 869976 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-26 03:16 EDT by Clayton Coleman
Modified: 2015-05-14 20:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: devenv_2096
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-19 14:27:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2012-08-26 03:16:00 EDT
Currently the site is hardcoding the default application creation domain in Rails config.  We need to show the domain as part of the form for creating an app.

Can we get "rhcloud.com" or "dev.rhcloud.com" returned on broker/rest/api ADD_DOMAIN?  Perhaps as an attribute of the "id" field like "parent_domain".  Or if there's a better place to return it (/broker/rest/domains).  We want to retrieve and cache the value for all users, although in the future I could imagine it being different for different domains/users.
Comment 1 Xiaoli Tian 2012-08-30 00:12:05 EDT
Move it to ON_QA, since the following pull request is merged in devenv_2096

https://github.com/openshift/crankcase/pull/445
Comment 2 Rony Gong 2012-08-30 05:22:11 EDT
Verified on devenv_2096

[rony@localhost qnodejs]$ curl -k -X GET -H 'Accept: application/xml' --user qgong@redhat.com:111111 https://ec2-50-16-77-243.compute-1.amazonaws.com/broker/rest/environment
<?xml version="1.0" encoding="UTF-8"?>
<response>
  <status>ok</status>
  <version>1.1</version>
  <type>environment</type>
  <data>
    <domain-suffix>dev.rhcloud.com</domain-suffix>
  </data>
  <supported-api-versions>
    <supported-api-version>1.0</supported-api-version>
    <supported-api-version>1.1</supported-api-version>
  </supported-api-versions>
  <messages/>
</response>
Comment 3 Ravi Sankar 2012-08-30 15:35:41 EDT
We can't provide domain suffix ('rhcloud.com' or 'dev.rhcloud.com) from 
broker/rest/api -> returns links and args are input params
broker/rest/domains -> returns domain object(s)

To make it more generic, I added another 'environment' link to broker/rest/api
...
{"GET_ENVIRONMENT":{
                     "optional_params":[],
                     "required_params":[],
                     "href":"https://localhost/broke/rest/environment",
                     "rel":"Get environment information",
                     "method":"GET"
                   }
}
...
broker/rest/environment returns 'key':'value' pairs (hash). Example shown in Comment 2.
If site needs any other values instead of hardcoding in site Rails config, we can add to this api.
Assigning to Clayton for corresponding site changes.
Comment 4 Clayton Coleman 2012-08-30 19:29:40 EDT
Thanks Ravi.
Comment 5 Clayton Coleman 2012-11-09 14:31:15 EST
*** Bug 869976 has been marked as a duplicate of this bug. ***
Comment 6 Yujie Zhang 2012-11-13 03:08:27 EST
(In reply to comment #5)
Tested on INT today, it still exists now, higher the severity in case it block the stage, thanks.
Comment 7 Clayton Coleman 2012-11-15 10:37:45 EST
This was fixed as of today.
Comment 8 Yujie Zhang 2012-11-16 01:30:39 EST
(In reply to comment #7)
Tested on INT today, it does not exist now, thanks.

Note You need to log in before you can comment on or make changes to this bug.