Bug 851932 - [Project List] Meaning of navigation button 2 and 5 are not clear
[Project List] Meaning of navigation button 2 and 5 are not clear
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
development
Unspecified Unspecified
low Severity low
: ---
: 2.0
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 00:37 EDT by Ding-Yi Chen
Modified: 2012-11-07 01:18 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.8.0-SNAPSHOT (20120926-0026)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 01:18:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-08-27 00:37:41 EDT
Description of problem:
On the project list page and file list page,
there are 6 navigation buttons on the page navigation bar.

From left to right:
 
  1.      2.    3.                     4.    5.     6.
<< <<    <<    prev  (Page numbers)   next   >>    >> >>

The first is clearly the "Go to first page", and the last is the "Last".

However, there is not obviously way to tell what button 2 and 5 actually means.

Version-Release number of selected component (if applicable):
Zanata version 1.8.0-SNAPSHOT (20120827-0014)


How reproducible:
Always

Steps to Reproduce:
1. Go to a project that have multiple pages of document (such as Skynet)
2. Mouse hovering on button 2 or button 5.
  
Actual results:
Nothing happen.

Expected results:
The actual meaning should show on either the button label, or the tool-tip.
Like "move to previous 5"

Additional info:
The behaviour of button 2 and 5 are just like "previous page" and "next page".
Comment 1 Alex Eng 2012-09-25 00:26:12 EDT
UI has been changed since bug report.
New page navigation: 
|<    <    1 2 3 4 5 6 7 8 9 10    >   >|
Comment 2 Ding-Yi Chen 2012-09-25 23:04:29 EDT
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20120926-0026)
Comment 3 Sean Flanigan 2012-11-07 01:18:36 EST
Fix released in Zanata 2.0.

Note You need to log in before you can comment on or make changes to this bug.