Bug 851962 - Geo-rep session started successfully even though one of the brick machine didn't have info about the session.
Geo-rep session started successfully even though one of the brick machine did...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Venky Shankar
Vijaykumar Koppad
:
Depends On:
Blocks: 850514 858472
  Show dependency treegraph
 
Reported: 2012-08-27 03:02 EDT by Vijaykumar Koppad
Modified: 2014-08-24 20:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.13rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 858472 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-08-27 03:02:51 EDT
Description of problem:Geo-rep session started successfully, even though it couldn't write the info about the geo-rep session in the file /var/lib/glusterd/vols/master/info in one of the brick machines. The reason it couldn't write the info was , that machine didn't have space in the root partition.


Version-Release number of selected component (if applicable): RHS-2.0.z


How reproducible: May be not consistent. 


Steps to Reproduce:
1.Create dist-rep volume for master. 
2.Fill up the root partition of one of the brick machine of the master.
3.Try to start geo-rep session. 
  
Actual results: the geo-rep start command succeeded


Expected results: It should fail with proper error message. 


Additional info:
Comment 2 Venky Shankar 2013-01-03 05:27:53 EST
Vijaykumar,

Could you please attache the logs if possible?
Comment 5 Amar Tumballi 2013-08-01 05:29:42 EDT
fixed with newer geo-replication implementation.
Comment 6 Vijaykumar Koppad 2013-08-07 09:39:19 EDT
since geo-rep got revamped since this bug, now the behavior is, if it fails to write to the file, it fails at commit stage, it doesn't fail completely, in the sense it will have inconsistent data over the cluster. There is a bug for that 
Bug 994549 

verified on  glusterfs-3.4.0.17rhs-1.el6rhs.x86_64
Comment 7 Scott Haines 2013-09-23 18:38:35 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 8 Scott Haines 2013-09-23 18:41:27 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.