Bug 851987 - Fedora 17 update failed
Fedora 17 update failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 04:35 EDT by sowe
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 09:02:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sowe 2012-08-27 04:35:33 EDT
Description of problem:
could not update Fedora 17

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.yum distro-sync
2.
3.
  
Actual results:
Modules complémentaires chargés : langpacks, presto, refresh-packagekit
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet avahi.x86_64 0:0.6.31-3.fc17 sera mis à jour
---> Le paquet avahi.x86_64 0:0.6.31-5.fc17 sera utilisé
---> Le paquet avahi-autoipd.x86_64 0:0.6.31-3.fc17 sera mis à jour
---> Le paquet avahi-autoipd.x86_64 0:0.6.31-5.fc17 sera utilisé
---> Le paquet avahi-glib.x86_64 0:0.6.31-3.fc17 sera mis à jour
---> Le paquet avahi-glib.x86_64 0:0.6.31-5.fc17 sera utilisé
---> Le paquet avahi-gobject.x86_64 0:0.6.31-3.fc17 sera mis à jour
---> Le paquet avahi-gobject.x86_64 0:0.6.31-5.fc17 sera utilisé
---> Le paquet avahi-libs.i686 0:0.6.31-3.fc17 sera mis à jour
---> Le paquet avahi-libs.x86_64 0:0.6.31-3.fc17 sera mis à jour
---> Le paquet avahi-libs.i686 0:0.6.31-5.fc17 sera utilisé
---> Le paquet avahi-libs.x86_64 0:0.6.31-5.fc17 sera utilisé
---> Le paquet avahi-ui.x86_64 0:0.6.31-3.fc17 sera mis à jour
---> Le paquet avahi-ui.x86_64 0:0.6.31-5.fc17 sera utilisé
---> Le paquet avahi-ui-gtk3.x86_64 0:0.6.31-3.fc17 sera mis à jour
---> Le paquet avahi-ui-gtk3.x86_64 0:0.6.31-5.fc17 sera utilisé
---> Le paquet cheese.x86_64 2:3.4.2-3.fc17 sera mis à jour
---> Le paquet cheese.x86_64 2:3.4.2-4.fc17 sera utilisé
---> Le paquet cheese-libs.x86_64 2:3.4.2-3.fc17 sera mis à jour
---> Le paquet cheese-libs.x86_64 2:3.4.2-4.fc17 sera utilisé
---> Le paquet crystalhd-firmware.noarch 0:3.5.1-1.fc14 sera mis à jour
---> Le paquet crystalhd-firmware.noarch 0:3.10.0-2.fc17 sera utilisé
---> Le paquet emacs-filesystem.x86_64 1:24.1-3.fc17 sera mis à jour
---> Le paquet emacs-filesystem.x86_64 1:24.1-4.fc17 sera utilisé
---> Le paquet exiv2-libs.x86_64 0:0.22-5.fc17 sera mis à jour
---> Le paquet exiv2-libs.x86_64 0:0.22-6.fc17 sera utilisé
---> Le paquet grep.x86_64 0:2.13-1.fc17 sera mis à jour
---> Le paquet grep.x86_64 0:2.14-1.fc17 sera utilisé
---> Le paquet iniparser.x86_64 0:3.0-1.fc17 sera mis à jour
---> Le paquet iniparser.x86_64 0:3.1-1.fc17 sera utilisé
---> Le paquet kde-settings.noarch 0:4.8-16.fc17 sera mis à jour
---> Le paquet kde-settings.noarch 0:4.8-18.fc17 sera utilisé
---> Le paquet kernel.x86_64 0:3.5.2-3.fc17 sera installé
---> Le paquet kernel-devel.x86_64 0:3.5.2-3.fc17 sera installé
---> Le paquet kernel-headers.x86_64 0:3.5.2-1.fc17 sera mis à jour
---> Le paquet kernel-headers.x86_64 0:3.5.2-3.fc17 sera utilisé
---> Le paquet kernel-tools.x86_64 0:3.5.2-1.fc17 sera mis à jour
---> Le paquet kernel-tools.x86_64 0:3.5.2-3.fc17 sera utilisé
---> Le paquet kmod-nvidia.x86_64 1:304.37-1.fc17.1 sera mis à jour
---> Le paquet kmod-nvidia.x86_64 1:304.37-1.fc17.2 sera utilisé
--> Traitement de la dépendance : kmod-nvidia-3.5.2-3.fc17.x86_64 >= 1:304.37-1.fc17.2 pour le paquet : 1:kmod-nvidia-304.37-1.fc17.2.x86_64
---> Le paquet libburn.x86_64 0:1.2.2-1.fc17 sera mis à jour
---> Le paquet libburn.x86_64 0:1.2.4-1.fc17 sera utilisé
---> Le paquet libcrystalhd.x86_64 0:3.5.1-1.fc14 sera mis à jour
---> Le paquet libcrystalhd.x86_64 0:3.10.0-2.fc17 sera utilisé
---> Le paquet libisofs.x86_64 0:1.2.2-1.fc17 sera mis à jour
---> Le paquet libisofs.x86_64 0:1.2.4-1.fc17 sera utilisé
---> Le paquet libquvi-scripts.noarch 0:0.4.4-1.fc17 sera mis à jour
---> Le paquet libquvi-scripts.noarch 0:0.4.7-1.fc17 sera utilisé
---> Le paquet minizip.x86_64 0:1.2.5-6.fc17 sera mis à jour
---> Le paquet minizip.x86_64 0:1.2.5-7.fc17 sera utilisé
---> Le paquet nspluginwrapper.i686 0:1.4.4-9.fc17 sera mis à jour
---> Le paquet nspluginwrapper.x86_64 0:1.4.4-9.fc17 sera mis à jour
---> Le paquet nspluginwrapper.i686 0:1.4.4-11.fc17 sera utilisé
---> Le paquet nspluginwrapper.x86_64 0:1.4.4-11.fc17 sera utilisé
---> Le paquet openldap.i686 0:2.4.31-7.fc17 sera mis à jour
---> Le paquet openldap.x86_64 0:2.4.31-7.fc17 sera mis à jour
---> Le paquet openldap.i686 0:2.4.32-2.fc17 sera utilisé
---> Le paquet openldap.x86_64 0:2.4.32-2.fc17 sera utilisé
---> Le paquet perf.x86_64 0:3.5.2-1.fc17 sera mis à jour
---> Le paquet perf.x86_64 0:3.5.2-3.fc17 sera utilisé
---> Le paquet python-urlgrabber.noarch 0:3.9.1-14.fc17 sera mis à jour
---> Le paquet python-urlgrabber.noarch 0:3.9.1-16.fc17 sera utilisé
---> Le paquet qt-settings.noarch 0:4.8-16.fc17 sera mis à jour
---> Le paquet qt-settings.noarch 0:4.8-18.fc17 sera utilisé
---> Le paquet ruby.x86_64 0:1.9.3.194-14.fc17 sera mis à jour
---> Le paquet ruby.x86_64 0:1.9.3.194-15.fc17 sera utilisé
---> Le paquet ruby-irb.noarch 0:1.9.3.194-14.fc17 sera mis à jour
---> Le paquet ruby-irb.noarch 0:1.9.3.194-15.fc17 sera utilisé
---> Le paquet ruby-libs.x86_64 0:1.9.3.194-14.fc17 sera mis à jour
---> Le paquet ruby-libs.x86_64 0:1.9.3.194-15.fc17 sera utilisé
---> Le paquet rubygem-bigdecimal.x86_64 0:1.1.0-14.fc17 sera mis à jour
---> Le paquet rubygem-bigdecimal.x86_64 0:1.1.0-15.fc17 sera utilisé
---> Le paquet rubygem-io-console.x86_64 0:0.3-14.fc17 sera mis à jour
---> Le paquet rubygem-io-console.x86_64 0:0.3-15.fc17 sera utilisé
---> Le paquet telepathy-gabble.x86_64 0:0.16.1-1.fc17 sera mis à jour
---> Le paquet telepathy-gabble.x86_64 0:0.16.2-1.fc17 sera utilisé
---> Le paquet virtuoso-opensource.x86_64 1:6.1.5-2.fc17 sera mis à jour
---> Le paquet virtuoso-opensource.x86_64 1:6.1.6-1.fc17 sera utilisé
---> Le paquet xorg-x11-server-Xorg.x86_64 0:1.12.2-4.fc17 sera mis à jour
---> Le paquet xorg-x11-server-Xorg.x86_64 0:1.12.3-1.fc17 sera utilisé
---> Le paquet xorg-x11-server-common.x86_64 0:1.12.2-4.fc17 sera mis à jour
---> Le paquet xorg-x11-server-common.x86_64 0:1.12.3-1.fc17 sera utilisé
---> Le paquet zlib.i686 0:1.2.5-6.fc17 sera mis à jour
---> Le paquet zlib.x86_64 0:1.2.5-6.fc17 sera mis à jour
---> Le paquet zlib.i686 0:1.2.5-7.fc17 sera utilisé
---> Le paquet zlib.x86_64 0:1.2.5-7.fc17 sera utilisé
--> Lancement de la transaction de test
---> Le paquet kmod-nvidia-3.5.2-3.fc17.x86_64.x86_64 1:304.37-1.fc17.2 sera installé
--> Résolution des dépendances terminée
--> Lancement de la transaction de test
---> Le paquet kernel.x86_64 0:3.5.0-2.fc17 sera effacé
--> Traitement de la dépendance : kernel-uname-r = 3.5.0-2.fc17.x86_64 pour le paquet : 1:kmod-nvidia-3.5.0-2.fc17.x86_64-304.32-1.fc17.x86_64
---> Le paquet kernel-devel.x86_64 0:3.5.0-2.fc17 sera effacé
--> Lancement de la transaction de test
---> Le paquet kmod-nvidia-3.5.0-2.fc17.x86_64.x86_64 1:304.32-1.fc17 sera effacé
--> Résolution des dépendances terminée

Dépendances résolues

===================================================================================================================================================================================================================
 Package                                                       Architecture                         Version                                          Dépôt                                                   Taille
===================================================================================================================================================================================================================
Installation de :
 kernel                                                        x86_64                               3.5.2-3.fc17                                     updates                                                  26 M
 kernel-devel                                                  x86_64                               3.5.2-3.fc17                                     updates                                                 7.5 M
Mise à jour :
 avahi                                                         x86_64                               0.6.31-5.fc17                                    updates                                                 254 k
 avahi-autoipd                                                 x86_64                               0.6.31-5.fc17                                    updates                                                  36 k
 avahi-glib                                                    x86_64                               0.6.31-5.fc17                                    updates                                                  22 k
 avahi-gobject                                                 x86_64                               0.6.31-5.fc17                                    updates                                                  32 k
 avahi-libs                                                    i686                                 0.6.31-5.fc17                                    updates                                                  57 k
 avahi-libs                                                    x86_64                               0.6.31-5.fc17                                    updates                                                  57 k
 avahi-ui                                                      x86_64                               0.6.31-5.fc17                                    updates                                                  34 k
 avahi-ui-gtk3                                                 x86_64                               0.6.31-5.fc17                                    updates                                                  34 k
 cheese                                                        x86_64                               2:3.4.2-4.fc17                                   updates                                                 2.8 M
 cheese-libs                                                   x86_64                               2:3.4.2-4.fc17                                   updates                                                 2.8 M
 crystalhd-firmware                                            noarch                               3.10.0-2.fc17                                    updates                                                 1.1 M
 emacs-filesystem                                              x86_64                               1:24.1-4.fc17                                    updates                                                  54 k
 exiv2-libs                                                    x86_64                               0.22-6.fc17                                      updates                                                 808 k
 grep                                                          x86_64                               2.14-1.fc17                                      updates                                                 319 k
 iniparser                                                     x86_64                               3.1-1.fc17                                       updates                                                  12 k
 kde-settings                                                  noarch                               4.8-18.fc17                                      updates                                                  50 k
 kernel-headers                                                x86_64                               3.5.2-3.fc17                                     updates                                                 847 k
 kernel-tools                                                  x86_64                               3.5.2-3.fc17                                     updates                                                 119 k
 kmod-nvidia                                                   x86_64                               1:304.37-1.fc17.2                                rpmfusion-nonfree-updates                                36 k
 libburn                                                       x86_64                               1.2.4-1.fc17                                     updates                                                 141 k
 libcrystalhd                                                  x86_64                               3.10.0-2.fc17                                    updates                                                  50 k
 libisofs                                                      x86_64                               1.2.4-1.fc17                                     updates                                                 395 k
 libquvi-scripts                                               noarch                               0.4.7-1.fc17                                     updates                                                  58 k
 minizip                                                       x86_64                               1.2.5-7.fc17                                     updates                                                  30 k
 nspluginwrapper                                               i686                                 1.4.4-11.fc17                                    updates                                                 151 k
 nspluginwrapper                                               x86_64                               1.4.4-11.fc17                                    updates                                                 147 k
 openldap                                                      i686                                 2.4.32-2.fc17                                    updates                                                 317 k
 openldap                                                      x86_64                               2.4.32-2.fc17                                    updates                                                 317 k
 perf                                                          x86_64                               3.5.2-3.fc17                                     updates                                                 502 k
 python-urlgrabber                                             noarch                               3.9.1-16.fc17                                    updates                                                 100 k
 qt-settings                                                   noarch                               4.8-18.fc17                                      updates                                                  26 k
 ruby                                                          x86_64                               1.9.3.194-15.fc17                                updates                                                 1.0 M
 ruby-irb                                                      noarch                               1.9.3.194-15.fc17                                updates                                                  72 k
 ruby-libs                                                     x86_64                               1.9.3.194-15.fc17                                updates                                                 2.5 M
 rubygem-bigdecimal                                            x86_64                               1.1.0-15.fc17                                    updates                                                  69 k
 rubygem-io-console                                            x86_64                               0.3-15.fc17                                      updates                                                  42 k
 telepathy-gabble                                              x86_64                               0.16.2-1.fc17                                    updates                                                 597 k
 virtuoso-opensource                                           x86_64                               1:6.1.6-1.fc17                                   updates                                                 3.3 M
 xorg-x11-server-Xorg                                          x86_64                               1.12.3-1.fc17                                    updates                                                 1.3 M
 xorg-x11-server-common                                        x86_64                               1.12.3-1.fc17                                    updates                                                  82 k
 zlib                                                          i686                                 1.2.5-7.fc17                                     updates                                                  84 k
 zlib                                                          x86_64                               1.2.5-7.fc17                                     updates                                                  83 k
Suppression :
 kernel                                                        x86_64                               3.5.0-2.fc17                                     @anaconda-0                                             115 M
 kernel-devel                                                  x86_64                               3.5.0-2.fc17                                     @anaconda-0                                              28 M
Installation pour dépendances :
 kmod-nvidia-3.5.2-3.fc17.x86_64                               x86_64                               1:304.37-1.fc17.2                                rpmfusion-nonfree-updates                               3.5 M
Suppression pour dépendances :
 kmod-nvidia-3.5.0-2.fc17.x86_64                               x86_64                               1:304.32-1.fc17                                  @anaconda-0                                              14 M

Résumé de la transaction
===================================================================================================================================================================================================================
Installation    2 Paquets (+1 Paquet en dépendance)
Mettre à jour  42 Paquets
Supprimer       2 Paquets (+1 Paquet en dépendance)

Taille totale  : 57 M
Est-ce correct [o/N] : o
Téléchargement des paquets :
Test de la transaction en cours
ERREUR lors de la vérification de la transaction avec les dépendances :
kernel-uname-r = 2.6.43.2-6.fc15.x86_64 is needed by (installed) kmod-nvidia-2.6.43.2-6.fc15.x86_64-1:280.13-4.fc15.3.x86_64
kernel-uname-r = 2.6.42.12-1.fc15.x86_64 is needed by (installed) kmod-nvidia-2.6.42.12-1.fc15.x86_64-1:280.13-4.fc15.x86_64
kernel-uname-r = 2.6.43.8-1.fc15.x86_64 is needed by (installed) kmod-nvidia-2.6.43.8-1.fc15.x86_64-1:280.13-4.fc15.6.x86_64
Veuillez reporter cette erreur dans https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** 8 problèmes RPMDB préexistants trouvés, la sortie de « yum check » est la suivante :
compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.x86_64 a des dépendances manquantes de libboost_serialization-mt.so.1.46.0()(64bit)
compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc15.x86_64 a des dépendances manquantes de libboost_serialization-mt.so.1.46.0()(64bit)
compiz-plugins-main-0.9.5.92-1.fc15.x86_64 a des dépendances manquantes de libboost_serialization-mt.so.1.46.0()(64bit)
1:kmod-nvidia-2.6.42.12-1.fc15.x86_64-280.13-4.fc15.x86_64 a des dépendances manquantes de kernel-uname-r = ('0', '2.6.42.12', '1.fc15.x86_64')
1:kmod-nvidia-2.6.43.2-6.fc15.x86_64-280.13-4.fc15.3.x86_64 a des dépendances manquantes de kernel-uname-r = ('0', '2.6.43.2', '6.fc15.x86_64')
1:kmod-nvidia-2.6.43.8-1.fc15.x86_64-280.13-4.fc15.6.x86_64 a des dépendances manquantes de kernel-uname-r = ('0', '2.6.43.8', '1.fc15.x86_64')
libcompizconfig-0.9.5.92-1.fc15.x86_64 a des dépendances manquantes de libboost_serialization-mt.so.1.46.0()(64bit)
libcompizconfig-0.9.5.92-1.fc15.x86_64 a des dépendances manquantes de libprotobuf.so.6()(64bit)
Votre transaction a été enregistrée, relancez-la avec :
 yum load-transaction /tmp/yum_save_tx.2012-08-27.10-26.gT926t.yumtx


Expected results:


Additional info:
Comment 1 Tim Lauridsen 2012-08-27 09:02:13 EDT
Look like you have some old kernel modules from rpmfusion installed, but is missing the matching kernels.

You should remove there old F15 packages and you will be able to update.

this is not a yum problem.

Note You need to log in before you can comment on or make changes to this bug.