Bug 851989 - Glusterd was unable to start due to unavailability of entry in one of the peer file.
Glusterd was unable to start due to unavailability of entry in one of the pe...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
Vijaykumar Koppad
:
Depends On:
Blocks: 858473
  Show dependency treegraph
 
Reported: 2012-08-27 05:00 EDT by Vijaykumar Koppad
Modified: 2015-11-03 18:04 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 858473 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-08-27 05:00:54 EDT
Description of problem: The glusterd was unable to write the entries in one the peer file , because of the lack of space on the root partition( most probably), but still glusterd was running, may be because it already had the information about the peer in the memory. But when you try to restart the glusterd , it fails in the init, even though the root partion has enough space. Although it has information about the other peers. It gets stuck in that state only until you rewrite the peer file manually. If it has the info about the other peers , then it should be able to get the info about peer it doesn't have info from the peers who have the information. 


Version-Release number of selected component (if applicable):RHS-2.0.z


How reproducible:Consistently 


Steps to Reproduce:
1.peer probe some four machines.
2.Remove entries from one of the file from one of machines.(don't remove file)  
3.Try to restart the glusterd of the machines from where you removes the entry.
  
Actual results: The glusterd fails in the init.


Expected results:The glusterd should start successfully.


Additional info:
Comment 2 Amar Tumballi 2012-08-29 07:14:31 EDT
Considering the bug is hit when the disk space was not available, not considering it blocker.
Comment 3 krishnan parthasarathi 2012-10-09 13:51:09 EDT
http://review.gluster.com/654 and http://review.gluster.com/3726 fix the issue on master. Need to review if we need this for 2.0.z branch.
Comment 4 Vijaykumar Koppad 2013-08-07 09:07:49 EDT
verified on glusterfs-3.4.0.17rhs-1.el6rhs.x86_64.
Comment 5 Scott Haines 2013-09-23 18:38:57 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:41:32 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.