Bug 852085 - cannot launch deployable w/ <service> tag
cannot launch deployable w/ <service> tag
Status: CLOSED NOTABUG
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jan Provaznik
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 11:07 EDT by dgao
Modified: 2012-08-29 10:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 15:53:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dgao 2012-08-27 11:07:55 EDT
Whenever launching a deployable w/ <services> tag, the status returned is "create_failed". No traceback from logs are observed.

[root@ibm-x3690x5-01 aeolus-conductor]# rpm -qa | grep "aeolus"
aeolus-conductor-0.13.0-0.20120824160007git202d4f9.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120824160007git202d4f9.fc16.noarch
aeolus-configserver-0.4.10-1.el6cf.noarch
rubygem-aeolus-image-0.6.0-0.20120824120030git6801a52.fc16.noarch
aeolus-all-0.13.0-0.20120824160007git202d4f9.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120824120026gitd64d64f.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120824160007git202d4f9.fc16.noarch
aeolus-configure-2.8.0-0.20120824120024gitbdcd549.fc16.noarch


deployable used:

<?xml version="1.0"?>
<deployable name="dgao_test" version="1.0">
  <description/>
  <assemblies>
    <assembly hwp="small-x86_64" name="Fedora-15-Audrey-Client">
      <image id="4ee653d4-ee26-11e1-8573-00215e5d12a0"/>
      <services>
        <service name='proxy'>
          <executable url='http://qeblade20.rhq.lab.eng.bos.redhat.com/pub/cloud-qe-script01.sh' />
        </service>
      </services>
    </assembly>
  </assemblies>
</deployable>
Comment 1 dgao 2012-08-27 15:53:10 EDT
This bug is caused by the oauth change in configserver. Without an additional patch on the conductor side, the communication breaks down and result in a 401 Unauthroized error. 

Closing this bz until the patch is applied to conductor, then retest.

Note You need to log in before you can comment on or make changes to this bug.