Bug 852143 - gluster volume reset of single option does not work.
gluster volume reset of single option does not work.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
Rahul Hinduja
:
Depends On: 847846
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 13:30 EDT by Vidya Sakar
Modified: 2013-09-23 18:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0qa5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 847846
Environment:
Last Closed: 2013-09-23 18:38:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-08-27 13:30:23 EDT
+++ This bug was initially created as a clone of Bug #847846 +++

Description of problem:
Problem exists even in 3.3.0
[root@pranithk-laptop ~]# gluster volume info
 
Volume Name: vol
Type: Distribute
Volume ID: 6f3224f5-f827-4764-9673-1c73fb75492e
Status: Created
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/tmp/0
Options Reconfigured:
diagnostics.client-log-level: DEBUG
[root@pranithk-laptop ~]# gluster volume reset vol client-log-level 
reset volume successful
[root@pranithk-laptop ~]# gluster volume info
 
Volume Name: vol
Type: Distribute
Volume ID: 6f3224f5-f827-4764-9673-1c73fb75492e
Status: Created
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/tmp/0
Options Reconfigured:
diagnostics.client-log-level: DEBUG
[root@pranithk-laptop ~]# gluster volume reset vol 
reset volume successful
[root@pranithk-laptop ~]# gluster volume info
 
Volume Name: vol
Type: Distribute
Volume ID: 6f3224f5-f827-4764-9673-1c73fb75492e
Status: Created
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: 192.168.122.1:/tmp/0
[root@pranithk-laptop ~]# 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Krutika Dhananjay 2012-10-09 04:31:00 EDT
http://review.gluster.org/#change,3901 merged in master.
Comment 3 Rahul Hinduja 2013-01-15 04:51:07 EST
Verified with build: glusterfs-3.4.0qa5-1.el6rhs.x86_64

Log Snippet:
===========


[01/15/13 - 09:48:36 root@dhcp159-57 ~]# gluster volume info
 
Volume Name: scount
Type: Distribute
Volume ID: 6a81487a-03dd-4bc3-a9f3-733eacf3ab69
Status: Started
Number of Bricks: 3
Transport-type: tcp
Bricks:
Brick1: 10.16.159.57:/home/s1
Brick2: 10.16.159.57:/home/s2
Brick3: 10.16.159.57:/home/s3
Options Reconfigured:
cluster.subvols-per-directory: 2
 
Volume Name: vol-rep
Type: Replicate
Volume ID: b9b2e304-195c-4051-9286-22e060b02175
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: 10.16.159.57:/home/rep
Brick2: 10.16.159.94:/home/rep
 
Volume Name: dis-rep
Type: Distributed-Replicate
Volume ID: 22e668a6-57f5-44cb-b0de-8a7c5b9d2095
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: 10.16.159.57:/home/dis-rep
Brick2: 10.16.159.94:/home/dis-rep
Brick3: 10.16.159.108:/home/dis-rep
Brick4: 10.16.159.211:/home/dis-rep
Options Reconfigured:
diagnostics.client-log-level: DEBUG
[01/15/13 - 09:48:40 root@dhcp159-57 ~]# 
[01/15/13 - 09:48:41 root@dhcp159-57 ~]# 
[01/15/13 - 09:48:42 root@dhcp159-57 ~]# 
[01/15/13 - 09:48:44 root@dhcp159-57 ~]# gluster volume reset dis-rep client-log-level
volume reset: success
[01/15/13 - 09:49:06 root@dhcp159-57 ~]# 
[01/15/13 - 09:49:07 root@dhcp159-57 ~]# 
[01/15/13 - 09:49:07 root@dhcp159-57 ~]# gluster volume info
 
Volume Name: scount
Type: Distribute
Volume ID: 6a81487a-03dd-4bc3-a9f3-733eacf3ab69
Status: Started
Number of Bricks: 3
Transport-type: tcp
Bricks:
Brick1: 10.16.159.57:/home/s1
Brick2: 10.16.159.57:/home/s2
Brick3: 10.16.159.57:/home/s3
Options Reconfigured:
cluster.subvols-per-directory: 2
 
Volume Name: vol-rep
Type: Replicate
Volume ID: b9b2e304-195c-4051-9286-22e060b02175
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: 10.16.159.57:/home/rep
Brick2: 10.16.159.94:/home/rep
 
Volume Name: dis-rep
Type: Distributed-Replicate
Volume ID: 22e668a6-57f5-44cb-b0de-8a7c5b9d2095
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: 10.16.159.57:/home/dis-rep
Brick2: 10.16.159.94:/home/dis-rep
Brick3: 10.16.159.108:/home/dis-rep
Brick4: 10.16.159.211:/home/dis-rep
[01/15/13 - 09:49:09 root@dhcp159-57 ~]# 
[01/15/13 - 09:49:11 root@dhcp159-57 ~]#
Comment 5 Scott Haines 2013-09-23 18:38:57 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:41:32 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.