Bug 852220 - [ORIGIN] failure after triggering a build in a embedd jenkins to a scaleable app
[ORIGIN] failure after triggering a build in a embedd jenkins to a scaleable app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 17:50 EDT by Peter Ruan
Modified: 2015-05-14 22:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: devenv_2313+
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 19:41:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2012-08-27 17:50:31 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create a scaleable app [rhc app create -a 2odxw8yswd -t php-5.3 -l admin -p admin -d  -s]
2. embed jenkins into app [rhc app cartridge add -a 2odxw8yswd -c jenkins-client-1.4 -l admin -p admin -d]
3. do some changes and commit & push to trigger a jenkin's build

Actual results:
stuck on Waiting for build to schedule..................................................................................

Expected results:
success

Additional info: 

here's a partial jenkins.log 


Aug 27, 2012 2:10:44 PM hudson.plugins.openshift.OpenShiftCloud provision
SEVERE: Exception caught trying to load existing slaves
com.openshift.client.InvalidCredentialsOpenShiftException: Your credentials are not authorized to access "https://127.0.0.1/broker/rest/user"
	at com.openshift.internal.client.RestService.request(RestService.java:97)
	at com.openshift.internal.client.RestService.request(RestService.java:89)
	at com.openshift.internal.client.RestService.request(RestService.java:74)
	at com.openshift.internal.client.AbstractOpenShiftResource$ServiceRequest.execute(AbstractOpenShiftResource.java:137)
	at com.openshift.internal.client.APIResource$GetUserRequest.execute(APIResource.java:234)
	at com.openshift.internal.client.APIResource.getUser(APIResource.java:93)
	at hudson.plugins.openshift.OpenShiftCloud.getSlaves(OpenShiftCloud.java:706)
	at hudson.plugins.openshift.OpenShiftCloud.provision(OpenShiftCloud.java:354)
	at hudson.slaves.NodeProvisioner.update(NodeProvisioner.java:227)
	at hudson.slaves.NodeProvisioner.access$000(NodeProvisioner.java:51)
	at hudson.slaves.NodeProvisioner$NodeProvisionerInvoker.doRun(NodeProvisioner.java:310)
	at hudson.triggers.SafeTimerTask.run(SafeTimerTask.java:54)
	at java.util.TimerThread.mainLoop(Timer.java:534)
	at java.util.TimerThread.run(Timer.java:484)
Caused by: com.openshift.internal.client.httpclient.UnauthorizedException: HTTP Basic: Access denied.

	at com.openshift.internal.client.httpclient.UrlConnectionHttpClient.createException(UrlConnectionHttpClient.java:185)
	at com.openshift.internal.client.httpclient.UrlConnectionHttpClient.get(UrlConnectionHttpClient.java:99)
	at com.openshift.internal.client.RestService.request(RestService.java:137)
	at com.openshift.internal.client.RestService.request(RestService.java:95)
	... 13 more
Caused by: java.io.IOException: Server returned HTTP response code: 401 for URL: https://127.0.0.1/broker/rest/user
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1403)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
	at com.openshift.internal.client.httpclient.UrlConnectionHttpClient.get(UrlConnectionHttpClient.java:94)
	... 15 more
Comment 1 Mike McGrath 2012-10-10 14:08:32 EDT
Re-assigning to dan mace as per bug triage meeting
Comment 2 Dan Mace 2012-10-10 14:10:06 EDT
This is the same as https://bugzilla.redhat.com/show_bug.cgi?id=863941.
Comment 3 Dan Mace 2012-10-11 10:15:30 EDT
Fixed in devenv_2313+
Comment 4 Peter Ruan 2012-12-21 01:03:14 EST
verified with the latest origin build on F17.
remote: 
remote: You can track your build at https://app1-test.example.com/job/2odxw8yswd-build
remote: 
remote: Waiting for build to schedule..............................................................Done
remote: Waiting for job to complete.....................

Note You need to log in before you can comment on or make changes to this bug.